View Full Version : G74sx problem with usb 3.0

11-09-2012, 03:57 PM
USB 3.0 does not work properly. I do not want to work with HD Western Digital WDBBEP0010BBK-01 (1 TB). The disk does not want to work at the port or in 2.0 or 3.0. Other devices work only in 2.0. I changed to a different hard WD 500 GB and the same. I changed drivers from oldest to newest. Moment and stops working properly. In the course of only a few dozen copies copying% and off. 2 WD and the same problem. Damaged USB 3.0 port? Please help! Thank you in advance! USB 2.0 devices are working properly in the USB 3.0 port. USB 3.0 devices do not want to work in a USB 3.0 port. Six months ago there were no such problems with any device.

11-09-2012, 04:27 PM
Just to confirm, you are reporting the WD USB 3.0 drive functioned properly on this system 6 months ago?

From what I've read on posts regarding this issue, the following appear important to resolution:

1) Installing the latest Fresco Logic USB 3.0 driver as well as the ASPatch contained in the installation file set.

2) Uninstalling (and reinstalling if you still want it) the ASUS Ai Charger Plus utility. Folks that report resolution from this procedure typically reinstall Ai Charger Plus. The increased voltage it applies to the port may be important to resolution.

Others have resolved the problem by troubleshooting the devices that attach to the port (i.e. obtaining a new or shorter cable for the device) . Check out this thread: http://rog.asus.com/forum/showthread.php?18855-USB-3-Problems. Western Digital appears to have some issues with their USB 3.0 drives and Windows 7.

11-09-2012, 11:26 PM
I tried all the possibilities. Drivers, etc. I conclude that there are two possibilities: Microsoft with new drivers or new driver Fresco. Fresco Z35740 even tested for Windows 8 Unfortunately, despite forcing it to install in W7 - does not work. There is only despair. Roads and bountiful G74SX notebook that does not have USB 3.0 working properly. This is pathetic and one great match! In my second: overrated Sony Vaio VPCF13M1E / H 2xUSB 3.0 (second year) everything works without a problem. I thought that Asus is a better company.

11-10-2012, 06:02 AM
Did you try updating firmware of the WD drive or the BIOS of your G74SX?

11-10-2012, 08:08 AM
Yes, of course, I did update the BIOS and firmware WD, but it did not help.
This is a problem only driver to USB 3.0 port.
Responsible for the Microsoft & Asus & Western Digital.
Notebook and WD are efficient in terms of physical and electronic.
I wonder whether Windows 8 will not be the problem? They write about fine tuning the controller and superlatives in transmission.

NEW ! ! !
Installed an old driver Fresco Logic USB 3.0 Host Controller v. and WD became visible to Win7. For now works properly. Prior to installing other older drivers Fresco and worked for a short time.:D

11-11-2012, 12:15 PM
Today I installed Windows 8 USB 3.0 does not work, even though the driver Fresco Logic USB 3.0 Win8 :(
I installed an older driver: USB3_Win7_64_Z301191 and saw WD system.
For me, this match to even the new Windows 8 did not support USB 3.0.
What makes sense to buy the inefficient system? :mad:

05-02-2015, 02:23 PM
I have a G74SX too, and had the same problem with USB 3.0 and Windows 8.1. Someone knows how ca we fix that problem? I tried to use any version or kind of drivers but, my USB 3.0 port don't work. Don't work in 3.0 and don't work with 2.0 too. Please, someone can help me? By the way, I am new in that forum, I don't know if I am writing the the right topic, sorry if I made a mistake. Tks

05-02-2015, 02:38 PM
Have you read dstrakele reply 2nd in this thread, you may have to find that driver version for 8.1 which might not be possible since I don't think anyone wrote new drivers for USB 3.0 since Windows now supports USB 3.0 Natively.

If all your other drivers including chipset drivers are up to date. You might try computer management/device manager/Intel USB 3.0 eXtensible Host Controller right click uninstall and reboot, the driver should reinstall itself hopefully not corrupted this time?

08-17-2015, 03:20 PM
Hello, I have the G74SX bought in 2011, and now I have windows 10 x64 installed, I have same issue... don't work USB 3. Has been solved this issue?

08-17-2015, 06:49 PM
Your the first one to have this issue. The window default USB 3.0 drivers work from 8.1 Intel has not written an update propriety USB 3.0 drivers so from Window 8 on the windows driver is the best we have. You could try opening Device manager and deleting the USB 3.0 extensive host Controller and reboot it should reinstall and hopefully work. The driver installed on my desktop is Microsoft 10.0.10240.16384 Dated 7/9/2015

This is the windows 10 USB 3.0 native driver

08-18-2015, 05:08 AM
Try these drivers which is
http://www.frescologic.com/file_dl.php?code=NDN8fEZMVVNCMy4wLTMuNi44LjA= (http://www.station-drivers.com/index.php?option=com_remository&Itemid=352&func=fileinfo&id=1642)

Win7 and Win10 both work fine on my G74SX using 3.5.93 drivers.