View Full Version : USB Port/FN issues after Win 8 Upgrade

11-10-2012, 11:52 PM
Hi all!

So I've had my Asus G74 for almost a year now and love it. I know some tech basics, but not super teach savvy.
So I'd really appreciate some help.

I've been doing some research, but am still at a loss.

Since I upgraded to Windows 8, I have 1 USB port not working, and my FN key functions are not working either.
I tried FN +F2 and that did work, but so far none of the other functions are working.

When I go to the Asus site to see if there's anything to update, I can't choose Windows 8 as my OS option for downloads, but if I go to G75 model I can.

So, can I try using G75 drivers/updates etc for my G74 or not? And if I can't does anyone know of any solutions that I can try for my issues.

Again I appreciate your time and help in advance!

Jocie =)

11-11-2012, 01:57 AM
The Function Key functions are supplied by the drivers in the ASUS ATK Package. You may have encountered this post in your research: http://rog.asus.com/forum/showthread.php?23359-Finally-took-the-Win8-plunge.. @zsld0423 reports he had success performing a clean install of Windows 8 (rather than an upgrade of Windows 7) and using ATK Package 1.0.014 on his G74SX.

You could try uninstalling your current ATK Package from "Control Panel - Uninstall a program", REBOOT, then install version 1.0.014, even if you are reinstalling it. If this fails, you may have to try the clean install route.

There is also a Fresco Logic USB 3.0 driver that supports Windows 8: http://drivers.softpedia.com/get/Other-DRIVERS-TOOLS/Fresco-Logic/Fresco-Logic-USB-30-Driver-35740-for-Windows-8.shtml. This may help with your USB issue if your problem port is the blue USB 3.0 port on the right side of your G74SX.

11-11-2012, 02:03 AM
Hi! I'm on a G74sx

As to the USB port, if it's your USB 3.0, I found a fix: "Go into your BIOS, and go to the 2nd tab. You should see an entry for USB CHARGE. Please enable this. This does the same as the AI Charger application."

I'm also having problems with my FN keys. Keyboard lights can't be modified, or volume, or even the touchpad enable/disable.
The only ones that work are the brightness, wifi on/off, screen on/off. I assume it's because windows 8 is more a tablet OS so those would be common buttons for a tablet (correct me if I'm wrong).

Please help with any fixes you have to restore the original functionality, after a clean install of Windows 8. Thanks!

11-11-2012, 02:24 AM
See my previous post. @zsld0423 reports he has those issues resolved.

11-11-2012, 03:15 AM
With the USB Issue, I lost the functionality of the USB2.0 port right next to the 3.0 one after installing the newest Fresco USB3.0 Driver. I literally had to do a system restore because uninstalling the new driver and installing an older version didn't work, it was very frustrating. And I think I had the USB charge enabled in the BIOS too.

And for the FN keys, yeah your best bet would be to uninstall the driver, and re-install the 1.0.014 version. But again, I did a clean install instead of an upgrade, so that could be your best option if the Fn keys still aren't working after that, because my keyboard and volume fn keys are working just fine

11-11-2012, 05:45 AM
Thanks so much for the help so far!

I will look into these options.

As far as a clean install, when I upgraded to Windows 8, before doing so I did a complete Factory Restore of my laptop, let it do some updates, and then proceeded to do the install of Windows 8.

That wouldn't be considered clean?

Would I have to purchase a CD to do a clean install?

Again thanks for the help!

Update: I tried installing the Fresco driver through the link you gave me dstrakele, that didn't work for the USB issue (and it is the blue one). Also, it seems I didn't have the ATK utility installed to begin with, but I found it on my product page. I simply chose WIndows 7 as my OS and downloaded it there and now all FN buttons are working EXCEPT FN + F9 the turning off the trackpad, which I suspect might be due to my not having a driver or something installed for that in the first place?

BlackStar I enabled the USB charge as well and it did nothing for me.

Now here is the frustrating part, after I had installed the ATK, and the AI Charger Plus (I had already installed Fresco) I restarted the PC and the USB port worked. I have my phone connected to it as my way of testing it. Well it lit up like it was being charged, but after a few seconds, it appeared disconnected again.

So I'm at a loss once more, but I'm going to try installing Fresco again because I uninstalled it to see if that did the trick and nothing.

11-11-2012, 06:26 AM
Last update for the night and seem most of my issue has been resolved.

I installed the lastest Fresco USB driver available from my product page, picking the Windows 7 OS, and the port is working!!

So happy right now =)

Thanks everyone for helping out!

Now to figure out how to get the FN+F9 working, and why when I'm typing my cursor will randomly move elsewhere -_-

11-11-2012, 01:23 PM
You need to install the driver for your touchpad and confirm it disables the touchpad when typing.

11-12-2012, 03:20 AM
Thanks after trying 4 different possible drivers, the 4th one was it. It was a Synaptics one that was able to installed. It created an extra options in my Mouse settings, and I ticked to disable the touchpad when USB was connected.

It did just that.

It still annoys me that my FN+F9 isn't working even with the driver installed, but there are worse things in the world!

All in all I think my set up is pretty good for now.

Thanks again for the help :)