View Full Version : asus g37j, Windows action center telling me i need to update nvidia drivers, but...

11-11-2012, 04:08 AM
I have an ATI radeon hd 5870 card. why is windows telling me to update my nvidia drivers? when i tried to install a driver update for nvidia anyway, it said no nvidia product detected.

Why do i care? Because I am consistently having problems running World of Warcraft, where everything and everyone just goes black. My ATI drivers are up to date, it says.

I'm at a loss for what to do at this point. I've looked everywhere for a solution.

Screenshots of what is continually happening:



11-11-2012, 05:44 AM
Have you flashed your vBIOS? Which drivers are you running? Newest WHQL certified drivers are

Also try switching from DX11 to DX9 in the graphics settings.

11-11-2012, 05:52 AM
idk what that means, have i flashed my vbios, or how to do it for that matter. i have no idea how to check anything, honestly. I just tried to update drivers like a week ago. ATI was up to date, told me nvidia wasn't, and i tried to install driver and it wouldn't let me. that's where i'm at.

I'm a bit frustrated, and ignorant of how this process works. so if there was some caring, understanding individual that wanted to help me out step by step in fixing the problem it'd be much appreciated.

11-11-2012, 06:27 AM
First - Start WoW then go to System, Advanced and change Graphics API to DX9 from DX11. Restart the game. Report back if you still have the black textures in the game.

Second - Ignore the nvidia stuff. You have an ATI Radeon 5870 not a Nvidia GeForce.

11-11-2012, 06:39 AM
Without reflashing the vBIOS (video bios) it is impossible to use anything other than the drivers provided on the driver CD or the ones on the ASUS driver website without receiving GSODs (grey screen of death). To use the newest drivers you must reflash your vBIOS. Instructions on how to do this are here:


Once you have done this you can download and install the newest ATI graphics mobility drivers using this link: