PDA

View Full Version : C: Drive Full (G75)



Djropi
11-14-2012, 01:11 AM
Well the inevitable has finally happened. Despite moving every installed program to one of the three other drives, I am finally running into less than 2gb of free space on the C: drive, which is obviously causing some problems for the G75.

It seems almost every single program wants to dump at least some files to C drive, and after trying to clean up for a few weeks I finally gave up and let everything run its course. Well now I am trying to install ableton live, and even though I select one of the other hard drives I am getting an error message that C does not have enough space.

Is there any remedy to temporary files being written to the C: drive? The space constantly seems to be going down even though I have nothing downloading to that drive, and I doubt chrome's cookies or whatever are taking up that much space. Is there a particular file/ folder I can clean to free up some room? Sitting on 1.3 GB on C right now.

Gracias

Myk SilentShadow
11-14-2012, 01:38 AM
Have you looked into disabling Hibernate? that can relieve your HDD/SSD of valuable real estate.

Zygomorphic
11-14-2012, 01:46 AM
Run system cleanup, thumbnails and temp files take up a ton of space. Especially if you have media programs that use the temp folder for scratch space. @Myk, your suggestion is also good. Depending on how much RAM you have, you can disable the swap file. If nothing else, make sure to use a different drive for your swap file. The SSD's life will increase and you will gain a bunch of space back.

rewben
11-14-2012, 01:52 AM
there should be a few places in your system that accumulate files:

1. C:\Users\<your.username>\AppData\Local\Temp - the common place for user temporary files
2. C:\Windows\Temp - use elevated command prompt to navigate into this;
3. C:\Windows\SoftwareDistribution\Download - windows update files; but some suggest that you use Disk Cleanup to clear the files;

some installers make a copy of itself and store it in C: but the locations vary from one to another.

the hibernate and page files also take up a lot of space if you have a good amount of RAM. you can disable hibernate using the command 'powercfg -h off' in an elevated command prompt. for the page file, some said adjusting this will cause havoc, but it really depends on your usage and the amount of RAM (i have 24GB so i turn it off totally).

Area 66
11-14-2012, 02:19 AM
page files can be move to the second HD

rewben
11-14-2012, 04:49 AM
@Area 66, a good point!

cheek
11-14-2012, 06:25 AM
google disk space fan. a little utility for view what **** is taking up the spaces. helps u to plan your course of action.

in elevated command prompt type powercfg -h off
this diasble hibernation.

old system restore points can also takes up a lot of space. u might have unwittingly allocated a lot for system restore?

itunes/torrent can gobble up a lot of space. i moved all of it to other drive using junction. thats using command mklink to create symbolic links. still works on win 8.

i let my pagefile remain on drive c. i just tweak the size. chances are if u have more than 8gb u wont need a lot of pagefile for normal usage.

GottiBoi55
11-14-2012, 06:41 AM
Here is a good free disk cleanup app that can help >>>>>>>> CCleaner, Click here to download. (http://www.piriform.com/ccleaner/download/standard)

Try this program, can help clean up your HDD.

Good luck, and enjoy!

Bran187
11-14-2012, 08:34 AM
Is it filling up because of things you are doing or is space magically disapearing?

Zygomorphic
11-14-2012, 11:12 AM
Set the size of the page file manually as the others have said. My page-file is auto-managed, I have 16 GB of RAM and the pagefile is 12 GB on disk.

Djropi
11-15-2012, 04:09 AM
Thanks for all the response everyone. Downloaded CCleaner and that cleared up some disk space, and I will try to disable hibernate as well.

Zygomorphic
11-15-2012, 11:31 AM
Glad all the collective wisdom helped! :) That is one of those things I don't understand...why Windows can't use the pagefile as the hiberfile as well...LINUX does. Then again, LINUX has to have a separate partition for the pagefile to hibernate into...

GottiBoi55
11-16-2012, 03:39 AM
Thanks for all the response everyone. Downloaded CCleaner and that cleared up some disk space, and I will try to disable hibernate as well.


One thing that works really well is to set your pagefile manually to the "recommended page size" , but set both the "Initial size" and the "Maximum size" to the same in value.
This way your drive will not write to the "pagefile", but you have the pagefile if you need it.

Try this and see how things work for you!

Good luck, and enjoy!

Skull6
11-16-2012, 04:11 PM
Setting both "initial size" & "Maximum size" grants the added benefit of not allowing the "accordion effect" of HDD storage to occur. Page file is always the same size, & if you make this change, update drivers & then defrag the HDD when you first get the laptop (right around the time you also make your recovery disks) (& do so BEFORE you start installing anything else), you'll be that much better off.

Quasimodem
11-17-2012, 04:59 AM
Something else that will help is going into your user folder... right click each icon such as Downloads, Documents, etc... They all have a location tab... Set it to a folder on your second drive...

aarbee
11-25-2012, 08:04 AM
I was under the impression that by deleting the hidden partition in the C drive, more space will be freed. On my G55 (whose C drive is an SSD) I have gone ahead and made backup of recovery disks and then deleted the factory default backup. However, this has not resulted in any increase in the available space on the C drive.
I have also moved the Recycle bin to the D drive. This has not released any space on the C drive either.
Can anyone please comment on the above issues and also advise as to how can I disable the hibernate feature to release more space on the C drive.
Cheers

rewben
11-25-2012, 08:29 AM
1. here (http://rog.asus.com/forum/showthread.php?25234-C-Drive-Full-(G75)&p=183945&viewfull=1#post183945) to disable hibernate;
2. move your pagefile to another drive if you can; alternatively, set a fixed amount of it; i disabled mine