PDA

View Full Version : Windows 8 + Ethernet on G74SX?



Ortopi
11-20-2012, 04:37 PM
Hi, today when I was trying to connect with the Ethernet-cable on my G74SX, it couldn't identify the network. I tried installing the Realtek LAN driver (it's from 2011), but the installation failed. Now I'm looking for a driver that's working, so I would be glad if anyone mind to help. :)

cl-scott
11-20-2012, 05:14 PM
While you're a bit sparse on the details, it sounds like the driver isn't the issue. It sounds like the physical connection is working, and that there's communication between the OS and the NIC. The problem seems to come more in getting some kind of a meaningful sharing of information between the NIC and whatever's on the other end (presumably a router). So I would suspect it's more likely an issue with the ethernet cable or the router than the driver. It's also possible that the ethernet port on the laptop is at fault, but I would say it sounds like your problem lies elsewhere from the driver. Unless you wish to share more details that might change the direction the blame seems to be leading.

Ortopi
11-20-2012, 05:40 PM
Oh my god, after upgrading the drivers and running all kinds of diagnostics, I finally thought "hey, what if I try to restart the router?". And guess what, it worked! Thanks for the help anyway, this forum is great.

dstrakele
11-20-2012, 05:49 PM
It's always a good idea to restart modem, router, and computer as a first troubleshooting step for network issues.

Ortopi
11-20-2012, 06:01 PM
Yes, I know. It's just that I've done it a thousand of times earlier, and it has never worked. Perhaps I should, though.

Another thing is that it worked on another computer, so I thought there was a problem with my own computer

cl-scott
11-20-2012, 06:25 PM
Oh my god, after upgrading the drivers and running all kinds of diagnostics, I finally thought "hey, what if I try to restart the router?". And guess what, it worked! Thanks for the help anyway, this forum is great.

There is a reason rebooting and making sure it's plugged in are still staples of troubleshooting. :D

http://www.youtube.com/watch?v=C2Ph8zwpNyI

dstrakele
11-20-2012, 10:06 PM
Where did you get that video of me at work?