PDA

View Full Version : G75 Sound Card and Audio Splitters



jdotjdot7
11-22-2012, 01:21 AM
Alright, after my Razer Carcharias died, I bought a Razer Kraken (their new successor to the Carcharias) the Kraken has better sound, comfort, and overall looks and feels more sturdy and nice. The thing is though, it is meant to also be able to be used as headphones meaning that it has 1 3.5mm jack you attach a splitter to that splits it into 2 cables, 1 3.5mm output, and 1 3.5mm mic input. Anyways, the after plugging in my Mic, i could hear sounds no problem, but noone could hear me. So i took my mic over to my old desktop (an ASUS CG1330-07) and plugged it into the back and it worked just fine. Perplexed I took it back to my G75 and i put the mic 1 centimeter from my mouth and talked and i heard myself (barely.) Anyways, i tried tinkering with it, set all the mic volumes up to max and nothing worked. Since it worked for my desktop, the only thing I could think of is the G75s sound card. I regot my Carcharias (sadly) and it works completely fine as far as the mic is concerned so it isn't the jack. So if it isn't the jack, and it isn't the headset, it is the G75 soundcard. I even uninstalled the VIA drivers, and even switched to Windows 8, nothing worked. Is there any way to fix this.

SUKARA@ASUS
11-22-2012, 03:55 AM
Remove all audio driver form control panel-->Add Remove Programs
and download the audio driver form asus website link,then re-install driver again!
http://support.asus.com/Download.aspx?SLanguage=zh-tw&p=3&s=388&m=G75VW&os=30&ft=4&f_name=Audio_VIA_Win7_64_Z600110600.zip#Audio_VIA_ Win7_64_Z600110600.zip

Also confirm again..
If you used the G75 onboard mic have any problem,working normal?

BJB3431
01-10-2013, 12:12 AM
I'm having the EXACT same problems with my G75 and the Kraken Pro.. Jdot, did Sukara's advice work? Onboard mic works fine, no problems.

Pitcher@asus
01-10-2013, 02:22 AM
please send to ASUS service center to check, if you do all software way but not help, maybe will HW problem.

farmerokbag
01-10-2013, 02:59 AM
me too,'m having the EXACT same problems with my G75 and the Kraken Pro.. Jdot, what happy.thank youhttp://www.oksky.us/imiss/images/3.gif