PDA

View Full Version : Asus G55vw keyboard won't light up



Chinksta
11-23-2012, 08:03 PM
Hey guys,

I've noticed this lately. Every time I put my G55vw on sleep and resume, the keyboard won't light up. I tried using the fn key + F4 or F3 and nothing happens. The keyboard would only lit up after I shutdown and restart it. Is this a fault on the machine?

wantedzai
11-23-2012, 09:08 PM
Sup, G55VW owner here. Just tried, Sleep>Resume = keyboard light works fine.

dstrakele
11-23-2012, 11:33 PM
The G55 keyboard backlight failure to work after Resume from Sleep is a BIOS issue introduced after initial BIOS version 204 and resolved in BIOS update version 214. See http://rog.asus.com/forum/showthread.php?18644-Problem-with-backlit-G55&p=182417&viewfull=1#post182417.

sing_css
11-24-2012, 12:38 PM
update BIOS to 2.14, it will solve this problem^^

ggBanks
11-24-2012, 01:16 PM
But c_man said that when he updated his BIOS to the 2.14 version, his computer wouldn't turn on when he pressed the power button.

rewben
11-24-2012, 02:08 PM
i think there are some configurations / models sold not compatible with bios 2.14. some reported success without weird symptoms.

my g55 has the power button frozen during shutdown/sleep.

ggBanks
11-25-2012, 10:30 AM
That's strange! They should have released a new update by now. By the way my G55 has the same problem with the keyboard back-light.

rewben
11-25-2012, 03:30 PM
i'm not sure what's going on; i would like to reset my cmos but i couldn't find a way to do that.

strangely, after i did several times of bios upgrades/downgrades (2.09 -> 2.14 -> 2.09), my keyboard back-light works now when i put it to sleep. i have disabled hibernate so only sleep is available.

c_man
11-25-2012, 03:46 PM
But c_man said that when he updated his BIOS to the 2.14 version, his computer wouldn't turn on when he pressed the power button.

Me, on 55? Are you sure?

My BIOS problem was on G75 and they fixed it with a new MB.

c_man
11-25-2012, 03:46 PM
On topic, this is a BIOS problem, update and it should work.

ggBanks
11-25-2012, 06:50 PM
I am sorry c_man I may have confused you with rewben. :(

c_man
11-26-2012, 10:03 AM
NP. I had a BIOS problem, but on G75.

rewben
11-26-2012, 02:09 PM
i should update that except for failed attempts to upgrade to 2.14 (frozen power button; need forced shutdown), my g55 is running nicely with bios 2.09.

the only problem left is the weird but minor usb3 'bugs'.

Pitcher@asus
11-28-2012, 02:19 AM
HI, chinksta is you problem fix now? and rewben what is your USB 3.0 bug?

rewben
11-28-2012, 03:05 AM
Mike_Lu@ASUS, it's my left-side usb port that's close to headphone jack. when i plug in any device, there is no safe removal of device icon in notification area (running windows 7).

my 'solution' for it is to use thumb drive only for that port. usb thumb drive is considered removable media (not external HDD). so i can just use windows explorer to eject it when it's not in use. as i said, a minor 'bug'.