PDA

View Full Version : G74Sx-3De Cineplayer BD player not playing 3D Blu Ray



Vergil
11-24-2012, 11:17 PM
I have a Asus G74Sx-3De with 16gb Ram 160GB SSD running Windows 7 Ultimate. This is the first time I am playing a 3D Blu Ray disc using the Cineplayer BD software that came with the computer. It is stating the following:

"The application could not read this copy protected disc. Please clean the disc or try another disc."

The disc is brand new "The Amazing Spiderman in 3D" so its not a clean issue. I am pretty sure its a software or drive issue. I checked the Asus site for updates and my laptop is up to date. I also went to the Roxio website and they don't have any updates as well. I also tried the help check for updates on cineplayer and it states:

"The Software Manager did not find updates for your application."

Are there any other people on here having the same issue if so how did you fix it?

Any help on this issue would be much appreciated.

Thanks,

Vergil

dstrakele
11-25-2012, 02:59 AM
It sounds like a Digital Rights Management issue. See http://rog.asus.com/forum/showthread.php?23257-blu-ray-player-issues.

SUKARA@ASUS
11-26-2012, 08:00 AM
Yes!!
Copyright protection mechanism,should be explained that!

Vergil
12-11-2012, 04:35 AM
I contacted ASUS and they are clueless on what they put on their own computers. They stated that it didn't come with the computer and told me to go to Roxio. Roxio is stating that the Cineplayer BD doesn't play 3D Blu-ray discs when there is a 3D Blu-ray logo on the bottom right corner of the start screen when you open the program. I did a screen shot and emailed them. They are giving me a run around as well stating that it is OEM software, it shouldn't matter if its OEM or not... it has their NAME on it, they created the software, I would think that they would have some support for their own programs. They directed me to their OEM website but the program wasn't even listed and they want to force you to upgrade but their is no upgrade option because its not on their list of programs that they supposedly created. WTF! What's the point of buying a 3D laptop if it can't play 3D movies out of the box! I have TotalMedia Theater 5 as a free to try and it plays 3D Blu-ray movies just fine, but it runs out in 15 days. I shouldn't have to pay $100 for a program after paying over a thousand dollars for a laptop that should have come with the program in the first place.

billyray520
12-13-2012, 02:22 PM
That's a sore spot with me too Vergil. I wonder how it can be fair that stand alone Blu-ray players can play any new Blu-ray disk you throw at them, no matter how old, but our computer Blu-ray players are somehow crippled so that ONLY constant software updates keep them functioning.

For example my G73 Blu-ray player and software from Cyberlink worked fine for about two years, then only an "upgrade" would get it working again. It seems all of the Software vendors, Cyberlink -PowerDVD, Corel WinDVD and Roxio CinePlayer, have all found the lucrative idea of forcing bi-annual "upgrades" to continue playing modern Blu-ray titles.

I think there needs to be a class action suit for price-fixing and whatever other consumer protection laws this violates. :mad:

dreamer94706
11-16-2013, 07:59 AM
I am having the same problem with Cineplayer BD on my ASUS laptop. I just purchased a new Blu-Ray DVD and have gotten the same ludicrous error messages when I tried to play the new DVD, while my older Blu-Ray DVDs are still playable using Cineplayer on the laptop. I gave up on Cineplayer and tried using a trial version of iDeer Blu-Ray Player for WIndows software. It did play my new Blu-Ray DVD so I bit the bullet & paid the $49.95 for a Full License and Lifetime Upgrades.