PDA

View Full Version : G74sx usb ports freezing



Selvaswami
11-25-2012, 07:35 PM
Hello;

My G47sx has started dropping its usb mouse every few minutes, then Windows 7 Pro (64-bit) would go ding as it found it again. I always runt it plugged in, through a good surge protector. It does this on all my usb 2.0 ports and on my usb 3.0 port. It does it on any of several usb mice models, and on my joystick, and on my headset.

I've updated my BIOS to 203, my intel chipset, my Fresco driver for the usb 3.0 port, and my Nvidia driver. My RealTek driver was already the latest. I've disabled the Synaptics touchpad in BIOS, I've forced Windows to write a new INFCACHE.1 file, I've uninstalled all the latest drivers to older versions, and one by one put them back to the latest ones. I've set advanced power settings to disable Suspend on the usb ports.

I've restored to a Restore point from a year ago. No luck.

The only thing I haven't done is recover it to factory build and start over, which I really don't want to do unless it's the only way.

Has anyone else had these kinds of issues and solved them?

Would an upgrade to Windows 8 solve this?

I even booted to a Live Ubuntu 12 CD to test another OS, and it still froze the USB mice every half minute.

Any advice would be a real help here.

Selvaswami

Pitcher@asus
11-26-2012, 03:55 AM
HI, did you try another USB mouse? did you uninstall ASUS utility the issue still happen or not? i suggest you back up your date and press F9 to restore again, if unable to help you please send to RC to check.

dstrakele
11-26-2012, 04:39 AM
Was it working without incident before? I don't like hearing you get the same issue in Ubuntu LiveCD. That makes it sound more like a hardware problem and likely the problem would persist in Windows 8.

Do you have other USB devices connected when your USB Mouse is having issues?

Did you try UNinstalling ASUS Ai Charger Plus from "Control Panel - Uninstall a program", rebooting, and reinstalling it?

Is "USB Charging" enabled in your BIOS? Since this is tied into voltage going to the USB ports as well as Ai Charger Plus, something screwy here could affect both Ubuntu and Windows OS'es.

Can you test with a different power adapter of similar or greater capacity?

Have you overclocked or otherwise made any performance modifications or configurations to your laptop?

cl-scott
11-26-2012, 05:22 PM
I'm going to agree that if it's happening with a Linux LiveCD, it's most likely a hardware issue. It's not a sure thing, but it is strongly suggestive. Does this only happen with the mouse or does it happen with other devices as well?

Selvaswami
11-28-2012, 12:44 PM
Hi, all and thanks for the input.

* Yes, tried several mouses,

* Yes, I reinstalled the ASUS live update utility and manually uninstalled, downloaded, and reinstalled the RealTek, Fresco, and Intel drivers,

* I have USB Charger on in BIOS so the software charger isn't needed

* I tested my AC adapter and it reads fine for 150 watts. I would never put a stronger wattage than that into my laptop.

* no overclocking at all. Have tried all Windows Power Options with no change.

* the only other USB thing plugged in as headset

* ASUS suggested updating the SATA driver so I did:
http://support.asus.com.cn/Download.aspx?SLanguage=en&p=3&s=336&m=G74Sx&os=30&ft=11&f_name=IRST_Win7_64_Z10101008.zip#IRST_Win7_64_Z10 101008.zip

that didn't change things.

* the occasional freezing happens with USB drives, headset, mouse, joystick

HOLD ON -- I think I just solved it. Or tripped over the solution.

I went into BIOS and turned off the Synaptics Touchpad permanently.
Windows announced on reboot that it could not recognize the Logitech mouse or load it on any port.
I plugged in a generic USB optical mouse and it worked fine without freezing on any USB port.

I uninstalled the software and driver for the 6-button Logitech mouse and rebooted to see if the 6-button mouse
would run on the mouse.sys driver. Nope. It freezes every ten seconds.

But the generic 2-button mouse runs beautifully -- it just ain't no gaming mouse.

So . . . this could be a power issue with the Touchpad interrupting the USB ports.
Could be the Synaptics driver needs to be returned to a previous version.
I'll test the hell out of this generic mouse on some games today, but it works fine right now.

I'll try a Cobra or Razr mouse on it.
I may end up reinstalling everything from scratch on this laptop anyway.
I hate not knowing exactly what's wrong when something's wrong.


Thanks again for the input. I'll update tomorrow.

dstrakele
11-28-2012, 01:05 PM
Are you 100% certain you have a Synaptics touchpad? G74SX laptops have also shipped with Sentelic touchpads.

I've seen in earlier threads where installation of a Synaptics driver changes the "Hardware Ids" property in Device Manager. The only way to truly identify the touchpad is to UNinstall the Synaptics touchpad driver from "Control Panel - Uninstall a program", REBOOT, so Windows can install its Plug-N-Play touchpad driver, and look at the touchpad Hardware Ids in Device Manager Properties.