PDA

View Full Version : G73JH USB Audio with pop's in Fresh win 8 install



Maheidem
11-30-2012, 02:14 AM
Hi Guys,

Let give a quick run down of what's happening. I did the windows 8 upgrade from my windows 7 installation. It was perfect, no problems at all.
But one day i tried starting up my pc and i was unable (for reasons unknown to me). So i did a format and installed windows 8.

All is fine as before. Except that my Razer Megalodon now keeps giving me some pops in the sound, pops and crackles. I know it's not hardware because it works fine in other pc's and i worked fine on my when i had the upgrade done from the default windows 7 install.

I can help but think this is a driver issue of some sort. Does any body have any ideia what might be happening?

Pitcher@asus
11-30-2012, 06:02 AM
hi, did you install win 8 audio driver for your USB audio, or you just used bundle driver or win 7 driver.

Maheidem
11-30-2012, 10:44 AM
hi, did you install win 8 audio driver for your USB audio, or you just used bundle driver or win 7 driver.

The Razer Megalodon don't use any specific driver. You just plug it in and let windows install the driver.

dstrakele
12-01-2012, 11:30 PM
If I were in your situation, I would install the Realtek 2.70 audio driver.

Maheidem
04-25-2013, 02:54 PM
So far, i´ve been unlucky...
tried all these alternatives e nothing...

Really frustaed with this.

Recently I noticed that my standard headset (with p2 connection) is also giving me some crackling sounds.

So i guess it is something that driver´s would solve.

This driver you recommended, from what i could see is just for the HDMI output right?