View Full Version : G75vw windows 8 USB 3.0 not working properly

12-01-2012, 11:56 AM
I installed windows 8 on my new G75vw and i noticed that the transfer speed on USB 3.0 is very low, is more like USB 2.0. I transferred a movie file to my mediaplayer (Egreat R300 with internal HD and USB 3.0) and the maximum speed transfer was 38 MB/s. I think it has to be much more. There is no USB 3.0 driver for windows 8, it is supposed to be included in the installation kit. Can you help me with this issue, pls?

Any idea pls? What speeds did you get?

12-03-2012, 02:58 AM
hi, please try to install USB 3.0 driver from http://downloadmirror.intel.com/21129/eng/Intel(R)_USB_3.0_eXtensible_Host_Controller_Driver .zip

12-03-2012, 12:24 PM
hi, please try to install USB 3.0 driver from http://downloadmirror.intel.com/21129/eng/Intel(R)_USB_3.0_eXtensible_Host_Controller_Driver .zip

Thanks for answering bat this driver is for windows 7, i think. I tried to install it but it says "This computer does not meet the minimum requirements for installing the software"

12-03-2012, 12:56 PM
hi jairo, i found this (http://communities.intel.com/message/173942#173942) (you're not alone; this topic is still under debate at intel). if you're interested, you can try this out.

it basically means the poster solved his usb 3.0 issue by using the latest chipset driver from intel. in that package, it contains the usb 3.0 drivers that work for windows 8. i found this (http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&ProdId=816&DwnldID=20775&ProductFamily=Software+Products&ProductLine=Chipset+Software&ProductProduct=Intel%C2%AE+Chipset+Software+Instal lation+Utility&lang=eng) to be the latest, instead of the original link from that post (for desktop boards).

edit: here is another alternative (http://plugable.com/2012/12/01/windows-8-and-intel-usb-3-0-host-controllers/). if you're OK with it, then just go ahead.

12-03-2012, 03:40 PM
The last chipset driver does not change anything, i have the same transfer speed. About the other method, i am not so comfortable to try, i have to reset windows and loose some data. i think i was wrong installing windows 8.

12-03-2012, 04:51 PM
In my experience transferring large files using USB 3.0 you are getting good transfer speeds. That's about the same transfer speed you would get with a internal SATA 11 5400 hard drive internally!! All these super fast speeds people are talking about are benchmarks also I have found that small files will transfer quite quickly. To insure you are connecting USB 3.0 benchmark your external drives USB 2 and then USB 3 you'll see that the benchmark should be about 2.5 times faster more or less. Actual file transfer will be much slower. This is true for Internal drives as well as external drives. I have found that USB 3 is just a little slower than eSATA for actual file transfers while they will benchmark pretty much the same. All this I speak of is using the same actual hard drive same external case same computer. I find this is consistent over the three computer I have that have USB 3. I could only test the eSATA on one computer as my G75 does not have eSATA nor my Wife's HP Envy touch screen. Regardless Bench mark your external drives that will tell you if you actual have a problem.

12-03-2012, 05:31 PM
Thanks, i will do that benchmark on my external HD (Western Digital Caviar Green 2000GB SATA3 64MB 5400RPM -this is the model i have in mediaplayer). If you say i am getting good transfer speeds ..you made me happy :) i thought it has to be 70MB+
Thanks again

12-03-2012, 08:35 PM
Well be sure to test both usb 2 and usb 3, and let us know how you come out. If your gettng 38 mbs with that drive it sounds pretty good to me I doubt that drive would bench more that 70 mbs installed in the puter.

04-07-2013, 03:12 AM
anyone found a solution to this yet? I've been frustrated with getting the usb 3.0 external drive to work more than 40mb per sec. I was able to get 240 read and 120 write on the desktop 3.0 ports but on my Asus G46 its 30-40 read and write. Whenever i plug it in it says this device might be faster if you connect thru usb 3.0 ports... I already have all the usb 3.0 drivers installed along with the newest one from intel few days ago. Nothing's working yet

04-07-2013, 03:24 AM
You may wants o just try and reinstall the dirvers over that the simplest solution

04-07-2013, 03:40 AM
already did, even installed older version of intel usb 3.0 drivers, including the one they released last week, also downloaded the ones from asus support, and tried different usb 3.0 drivers but nothing helps to get the speed same as desktop usb 3.0.. i thought all ports were created equal lol

04-08-2013, 03:22 AM
Sounds like you may have a defective NB, If your cables are good and work on your Desktop, they should work on your NB, yet is sounds like your only connecting at USB 2.0. Also you are on Win 8, Microsoft has a native USB 3.0 driver.
In my experience sustained transfer rates of 30 40 MBS is normal for USB 3.0, Benchmarks will be much higher but actual transfer rates not so. This is true for me using Vantec USB 3.0 enclosures with Hitachi 7K 500 HD

04-08-2013, 07:33 AM
establish something first. your ports are probably not defective. don not rma until you are very very sure. is your usb 3.0 device when connected to g75vw indeed operating at usb 3.0?
unsure? read this

if yes and you run at lower speed. pls understand this. your desktop has a different board and can can thus possibly transfer at better speed. and NO not all usb ports are created equal.
you can try the fix here. as reuben has pointed out.
this fix is not guranteed to work as it is dependant on your particular usb device. FYI it didnt work for ALL of my usb 3.0 device. namely corsair voyager gt 3.0, toshiab canvio 1tb 3.0, some generic usb 3.0 enclosure.

intel will not release any usb 3.0 drivers (as of writing). ball is in windows court.
and as u already know. the windows 7 intels drivers are NOT for windows 8. dont bother to get them to install.
i ended up sticking with the original crappy windows usb 3.0 drivers. tested and bought the sandisk cruzer extreme 64gb. works at blazing speed. and my generic usb 3.0 enclosure and toshiba canvio 3.0 works as well at reported speed. but my corsair voyager gt 3.0 still only get recognize at usb 2.0
you can consider the very drastic move of going to win 7 if it you have a copy and u really need usb 3.0 to work.

i blame windows in all of this.

09-02-2013, 09:33 AM
Try this:
Go into BIOS (hit delete during the ROG logo on startup)
Switch to the "Advanced" page
Go into the "USB Configuration" menu (second from bottom)
Go to the "USB Legacy Support" option.

By default, this is set to [AUTO]. Set it to [Disabled].

Hit F10 to save and exit.
Boot into windows, and try your transfer again.

I'm on Windows 7, so this may not be directly applicable to you but after scouring the net for info, downloading both the ASUS and INTEL provided USB3 drivers, messing about in device manager, and trying absolutely every software procedure I could, as well as looking through the bios for anything that seemed remotely related, I started flipping random USB switches. This one did it. I was getting ~35MBps before and now I'm transferring files at 85MBps off an external RAID5 array right now. Why, exactly Legacy support forces the hardware into USB2 mode *all the time* when set to AUTO, why that would be the default if so, and why they don't describe this as a potential side effect, I'll never know. But then, after owning as many ASUS products as I have, you'd think that I'd know better than to trust what they say things do in BIOS. :rolleyes:

10-18-2013, 05:11 PM
Hi ! I have asus g75vw-bbk5 notebook Windows 8 Pro. Yesterday I still had USB 3.0 slow speed. But today I found my usb 3.0 speed is about
100 MB/S. I did check device manager and found new driver from microsoft for usb 3.0 controller and usb root hub xHCI which I did not see
yesterday. All 4 usb 3.0 ports working good. I did not do any changes on notebook by myself, it came automatically. Good luck for everyone. Sorry for my english.