PDA

View Full Version : Planet side 2



ChillKill
12-08-2012, 09:27 PM
hey guys anybody playing this games what fps are you getting ?

g75 / 660m overclocked +135 core +500 mem / driver 310.70

im getting between 20 - 30 fps at high settings / 1920 x 1080

mrwolf
12-09-2012, 12:45 AM
Yea Planetside 2 is quite a demanding game and currently needs more optimization.. Ive a got a G75 with 670M and have managed to get it running at 45-80 fps on pretty much high settings with Mid OC - 700/1650 :) will share some tips with you..

To get the most out of it, you need to know that planetside 2 is heavily CPU intensive. You can see what is limiting your fps when you press ALF-F in game. A small fps counter with either CPU or GPU next to it will appear on the bottom left.

Optimize your CPU:

In certain situations where you may find yourself in a HUGE battle with alott of infantry it becomes laggy and fps drops, for me when this is happening the fps counter will hit all time low fps at about 20-30 fps, and it would say CPU on the bottom left indicating that my CPU is limiting fps.
To get the most out of your CPU, you should go ahead and Unpark all your cores. Heres a guide i put up eariler:

http://rog.asus.com/forum/showthread.php?26087-CPU-Unparking-How-to-unleash-your-currently-limited-Ivy-Bridge&country=&status=

After Un-parking all my cores i noticed a huge improvement in those BIG indoor firefights where CPU was limiting me and also sometimes when flying over a huge warzone.. I gained a full 10 fps by doing this so now it is stable at 30-40 fps which makes it completely playable for now,until they optimize the game further..

Nvidia Control Panel settings:

For me so far, these are the optimal settings for PS2 - Screen set at 120hz with adaptive v-sync and in game v-sync off

14732

Certain settings in game that can help:

Turn Fog shadows OFF
Set Render Quality to 90%
Turn Motion-Blur OFF
Set Shadows to Medium.
Turn V-sync OFF
Keep everything else HIGH

Then restart the game n give it a go.

ChillKill
12-09-2012, 02:07 AM
wow thanks very much, i followed the guide all good.
one thing tho i cant put 120hz i wont let me theres no option

mrwolf
12-09-2012, 02:20 AM
Ah your welcome :).. Dont worry about the 120hz thing, thats only if your screen is 3d screen otherwise its cool at 60hz..

ChillKill
12-09-2012, 02:28 AM
well after unparking all cpus everything runs faster. thanksss

ChillKill
12-12-2012, 02:55 PM
well after unparking all cpus , overclocking my gpu , im only able to play confortably with low settings , in heavy battle 25-30 fps and in empty place 60 fps

anyone else plays this game? can you share your fps

mrwolf
12-12-2012, 06:13 PM
hmm thats very strange. I thought my settings and stuff helped you..?

Basically try to use High settings, because some of the low settings enable texture downscaling and alot of bollox that for some strange reason gives lower fps for higher end machines.. Otherwise it is normal to get 25-30 in extreme situations because CPU is getting bottlenecked. This is not a problem with your machine, but the game engine. It is not fully optimized and i can guarentee 100% in the next couple of months this game will be running with everything maxxed out 45+fps stable... They jus have to do alot of tweaking and balance CPU-GPU usage properly.

Try these settings:

Turn Fog shadows OFF
Set Render Quality to 90% or 85% (this helps ALOT in terms of fps)
Turn Motion-Blur OFF
Set Shadows to Medium.
Turn V-sync OFF
Keep everything else HIGH

lilfoot95
12-12-2012, 06:56 PM
I noticed that in most games with the 660m that Shadows and Ambient Occlusion lower your FPS a lot, you could try lower them to low(or off) and see if it helps

ChillKill
12-12-2012, 07:30 PM
ok and what about brightness ?

mrwolf
12-12-2012, 09:02 PM
Yea you could try putting shadows down to low and see how that works.. Brightness should'nt really make any difference..

Artiom-TOU
03-11-2013, 01:51 PM
I know, it's a bit late to write, but Thank you, man! Turned off Parking and Overclocked my 660M to +150GPU/+400MEM and Now PlanetSide 2 is working on 50 FPS FullHD without any problems on all Maxed Out.... Just thank you, you're my nervous saver ;)

mrwolf
03-11-2013, 06:24 PM
Ah your welcome m8 :)

By the way are you sure you are playing the game maxed out ? Only way to bring out ULTRA settings is to edit .ini file.

If you like this game as much as i do then make sure you have a look at my full updated optimization guide, have added true Ultra settings spec aswell as the recommended G75 config and ways to enable Particle PhysX..

http://rog.asus.com/forum/showthread.php?27496-Planetside-2-Optimization-Guide&country=&status=