View Full Version : G74sx Sentalic touchpad

12-11-2012, 06:49 AM
Ok so the touchpad on this laptop is wanting me to throw it away, i don't know if it's naturally like this, or if there's something wrong with it. it's been that way since i got it.

Ok so, the touchpad either gets EXTREMELY unsensitive, to the point where even if i push real hard it won't move a mm , or gets extremely sensitive that when i move it down, goes down , then flares up , and sometimes its just i need to press hard to move it around.

conclusion : Touchpad's really annoying me.

I'm on sentelic atm , ( I've tried and it didn't get any better )
I tried uninstalling, rebooting, installing, rebooting, and still nothing.

Bios : American Megatends Inc. G74sx.201 . 4/27/2011

Help would be very appreciated, thanks!

12-12-2012, 05:37 AM
hi, did you send back to ASUS service center to check it, not SW problem, maybe HW probem.

12-12-2012, 08:03 AM
I plan to send it on thursday, they're so slow ehre though and the problem's that sometimes , it works fine, so they might think " hey it's ok "

12-13-2012, 09:54 PM
See the many other threads about this. I find it hard to believe that theres been so many people with problems with this touchpad that Asus hasn't done anything about it. A serious lack of caring about customer satisfaction imho. I love my machine, and tell everyone I know this, but also tell them about the horrid support.