View Full Version : Its stuck on the loading screen

12-14-2012, 03:16 AM
It's stuck and won't get past the loading screen tried switching back and forth from the ssd too the USB recovery and it won't load ,it's been loading for an hour....anybody know what's happening?It stays on the logo screen

12-15-2012, 10:33 AM
It stuck on the ROG logo loading even when I use the recovery startup USB stick I went into bios and tried a couple things but still can't make it past loading logo should I leave it on for a day?

12-15-2012, 04:06 PM
I would suggest you contact the vendor who you bought your system from and ask them to provide support.

All I can suggest is to clear the CMOS but that will remove your built in overclock.

07-29-2014, 04:02 PM
my rog tytan g50ab pc is stuck on logo screen. del,f9,f8, doesnt work.
i downloaded MAXIMUS-VI-HERO-ASUS-G50AB-0701.CAP file(the latest one: dated march 2014) and i put it in fat32 formatted flashdrive and when i push flashback button after 4 seconds blinking stops. so nothing works... im starting to regret why i bought this pc...
please help!!!!

07-29-2014, 08:30 PM
Im experiencing the same problem. I bought it yesterday and it wont go past the windows loading animation. Im also starting to regret buying the "Asus Maximus vii Hero"
I would love some help with a solution.