PDA

View Full Version : G75VX Missing "d3dx9_43.dll", "xinput1_3.dll" & DX reinstall not work: gaming imposs.



party_arty
01-02-2013, 10:35 PM
Hello everybody,
i just received my newly bought G75VX at max configuration with pre-installed windows 8 64bit. but here comes the bad news: i constantly get error messages when starting games like world of tanks or fallout new vegas complaining about missing directX dlls.
everything in the direction of reinstalling the game or trying to fix the built in directX fails. even the web-installer from microsoft fails. the "d3dx9_43.dll" is missing as well as the "xinput1_3.dll". the directX installer fails crying about the already existent "d3dx9_24.dll". i've also tried to unregister/delete directX from the registry (HKLM\...) and trying to reinstall - nothing helps. iam really upset with this issue of this "gaming" notebook, 'cause it acutally isnt able to handle games. i lost half a day with absolutely no non negative result.
i'd appreciate any help on this manner, which proofs me one more time, that simply plug and play of new stuff doesnt work :(

Myk SilentShadow
01-03-2013, 12:03 AM
Try downloading and installing this, June 2010 DirectX 9 Redistributable.

https://www.microsoft.com/en-au/download/details.aspx?id=8109

_
01-03-2013, 01:39 AM
Tried an F9 factory reset?
Are the games legit - are you installing from Steam for example?

party_arty
01-03-2013, 09:57 AM
i tried the redistributable, which is complaining, too. these games are stand alone. nothing like steam is involved.
edit: i will try the factory reset and report.

party_arty
01-03-2013, 11:27 AM
ok. i tried the system restore and it works now. it seems that the shipped installation of win8 was corrupted. the game world of tanks now correctly updates his needed directX stuff and runs perfectly. all of the missed files are now present in the system folder.
thanks for the hint.

Eleiyas
07-25-2017, 07:14 PM
This thread is from 2013, please do not bump such old threads.

Closing thread due to age.