View Full Version : G73SW-XR1 with Vertex 3 SSD limited to SATA 2 speeds

06-24-2011, 01:01 AM
Hi, 1st timer here. Got myself a nice G73SW-XR1, came with a slow 5400rpm HDD so I replaced it with Vertex 3 120 GB SSD to take advantage of SATA 3 speed. Unfortunatelly I'm stuck at SATA 2 speeds. Something is holding it back. Please help guys!

06-24-2011, 01:11 AM
I'm pretty sure that the G73 family only supports SATA2. I could be wrong though. Still a freakishly fast drive. I'm thinking about getting an Agility 3 for my desktop.

06-24-2011, 04:00 AM
I'm sorry, I have G53SW-XR1 not G73SW-XR1. So does that support SATA3 for SSD and if so how do I enable it?

06-24-2011, 04:22 AM
Unfortunately, none of the G53, G73 or even the new G74 laptops support SATA3. There isn't any way to enable it since it's just not there.

06-24-2011, 12:22 PM
Are you sure about that? Everywhere I read it said that beginning with Sandy Bridge models SATA3 6gb/sec is supported. I certainly wouldn't have bought SATA3 Vertex 3 if I read otherwise.

06-24-2011, 01:23 PM
On intels site it says this chipset support 6Gbit/sec.


06-24-2011, 04:25 PM
Exactly, that's why I'm scrtching my head why I'm only getting SATA2 speeds on my laptop. It's brand new, after Intel's revision of the SATA bug found earlier this year. Should work! Anybody know what to do to make it happen?

06-27-2011, 07:23 PM
I have G73SW + Vertex 3 and it _IS_ working at SATA3 speeds. No problem. I have G73SW-91015Z (aka 3DE with 460M/8G/2x500GB).

I replaced the first (system) drive with the SSD, SATA3 worked since the beginning. The only problems I encountered were LSPM/power management issues with the Intel RST driver (you have to disable it or you b0rk the drive!) and a quirky firmware upgrade (so far my OS survived).

One reason SATA3 may not be working for you could be cabling - SATA3 is more demanding than SATA2 and since all G73SW originaly needs are SATA2 speeds, it's possible the cabling is inferior in some units rendering SATA3 unusable (and the controller retards to SATA2).

Download hwinfo32 and look at the drive and chipset, whether both support 6Gb signaling...

Anyway, I don't think you'll notice SATA2 x SATA3 anywhere but benchmarks, random read/write is not that good :/

06-27-2011, 10:52 PM
Ahh, I stand corrected. I was reading from the Asus site and it was saying that it's Sata2, so it's very likely that they did use cabling that is iffy for Sata3 but passes muster for Sata2. Depending on what you're doing with it, you might not notice too much of a difference anyway. It is a good thing to track down to find out, though.

07-03-2011, 06:51 PM
Thanks for trying to help me guys. I downloaded HWiNFO64 to see if I can find out if drive and chipset report 6Gb signaling but I don't find such info in the tool. Can you point me to it? Attached I captured some diagnostics.
So if this is cabling issue, can I replace it myself with a better quality one for my laptop?
I contacted Asus about his about a week ago and even thou it says response in 48 hrs I still haven't gotten it.

07-03-2011, 07:38 PM
You could try uninstalling the RST drivers, and use the MS AHCI driver.

07-07-2011, 11:45 AM
You could try uninstalling the RST drivers, and use the MS AHCI driver.

You could also use the Intel Series 6 AHCI drivers as well. Intel RST seems to keep us in SATA 2.

07-22-2011, 03:26 AM
Thanks for trying to help me guys. I uninstalled Intel RST to default it to MS AHCI. Sure enough I started getting read speeds in mid 400's. Cool but the 1st sign of problem came with neither ATTO nor CristalDisc being able to complete write test, both throwing an error. Then I experienced a couple of BSODs. I'd like to try Intel Series 6 AHCI drivers to see if I get better luck with those but I'm having a hard time finding them on Intel's site. Can you point me please?

07-23-2011, 12:27 AM
I linked them on my Driver page. Grab the 10.0.xxx set

07-23-2011, 04:01 PM
I installed Intel RAID and AHCI with GUI and I'm back to SATA2 speeds. Looks like only Microsoft AHCI will give me SATA3 but for for some reason it's unstable for me. Errr. Should have gone with Intel of Crucial on SSD...

07-23-2011, 09:11 PM
Any firmware updates for your SSD?

07-24-2011, 06:41 AM
Try - http://www2010.gigabyte.eu/Support/Motherboard/Utility_DownloadFile.aspx?FileType=Utility&FileID=183
to check for SATA 3. Worked on my G73SW.