PDA

View Full Version : ASUS G53SW - SATA 3 AHCI Operation Problems (Needs a BIOS Update here)



Godaemon
01-05-2013, 11:50 PM
I installed a Samsung 840 pro 128GB (updated with the latest FW) and tried to install Win7 in AHCI mode.
No luck.

Got errors like "A read Disk Error Occured" before the windows boot.
Most of the times windows refuse to boot.

I also tried a Corsair Neutron and a Vertex4.
Same problems with every model when running in Sata 3 and AHCI.

There is also another post related to this
http://rog.asus.com/forum/showthread.php?27298-Help-Me-Asus-G53SW-SSD-Corsair-Neutron-240GB

Someone needs to do something here.
Like i said in the other post

"There are severe compatability issues when you try to operate under SATA 3 in AHCI Mode (IDE works fine).

The PROBLEM HERE IS THE LAPTOPs obsolete modules inside the BIOS.
These modules need to be updated to the latest versions for the laptop to work as it is supposed to work.
In short we have to beg ASUS to care about us and release a new BIOS
All these months ASUS has not released a single updated BIOS for an enthusiast product. Unacceptable.Terrible.

Put aside the other issues with the thermal throttling and the no AES support feature in the CPU. (thank God there are people out there who worked on it)

DO YOU HEAR US ASUS? ALL THE OWNERS of the G53SW , this is called terrible customer support.

I have tried everything, i have read tutorials on how to update the modules inside the bios but when i reached the final step i realized that this laptop's bios is not using the same intel RST rom modules inside the bios like the desktop boards do , so ultimately it is up to them to decide to do their job and fix our issues..

I emailed them yesterday, i hope for a reply.

If there is anyone here from ASUS reading my post.. PLZ DO SOMETHING AT LAST!

We want the laptop that we bought to work like advertised.. "

dstrakele
01-06-2013, 12:31 AM
Here's a video of a user that got a G53SW to boot Windows 7 successfully on an SSD: http://m.youtube.com/#/watch?v=glQwcRewHus&desktop_uri=%2Fwatch%3Fv%3DglQwcRewHus. Unfortunately, neither he nor you list the BIOS version.

Godaemon
01-06-2013, 12:42 AM
The Sata III Controller works fine in AHCI mode with all SATA 2 SSDs and is also known to work good with some older Sata 3 SSDs like the Intel 510/330 or Crucial M4 and (if i remember correctly) with Samsung 830 and older series.

The problem is with the latest models.

G53SW-XN1 and My Bios is 203, thats the only one available.
Like i told, no BIOS update since the day of the release

dstrakele
01-06-2013, 01:21 AM
I wish you "Good Luck" on your request for an ASUS G53SW BIOS update to address the issue. Unfortunately, I believe it is less likely than being mauled by a Grizzly Bear, then mauled by a Black Bear, then being struck struck by a meteor on the same day...

Godaemon
01-06-2013, 04:45 AM
I am not obliged to search for third party mods , tricks etc to make my laptop work properly.

I wont stop unless they give a solution to their customers.
Not only for me but for all these people who support asus and buy ASUS Products. :mad:

Pitcher@asus
01-08-2013, 07:20 AM
hi, did you pass to ASUS service center? what is your SSD model name?

Godaemon
01-10-2013, 03:51 AM
My SSD is a Samsung 840 Pro Series , 128GB Version

http://www.samsung.com/us/computer/memory-storage/MZ-7PD128BW

After communicating with ASUS i got the following response

Dear customer,

Regarding the described problem, we have already forwarded your notice at the responsable department. The problem can be solved only with a new version of BIOS of the NB.

For information and Technical Support, please try to contact the Greek Support at: 00800 44142044 ( TOLL FREE ) (not available from mobile phones and VoiP phones) (09am to 13pm - 14pm to 19pm, Monday to Friday). ( From Cyprus: 800 92491 )
Email: support@asus.gr

I am glad that they recognize the problem but to be honest i dont expect a solution..
Hope i am wrong..

Godaemon
01-11-2013, 01:26 AM
Still working on it and trying to find a solution.

I managed to unlock a few more BIOS features.

Since there is an SSD present on SATA Port 0 I tried to disable the ALPM (aggressive link power management)on that port and also enable the hot plug support to check whether it's a power related problem which prevents the proper detection of the SSD while operating in AHCI mode.

Result:
Problem persists.

I tried to replace a few BIOS modules like the CSMCORE, AHCI and Cougar Point RC using the newer modules from the G53SX model but I did something stupid and replaced a few more modules which I shouldn't and I ended up with a bricked laptop. :-)

I am currently waiting for a new bios chip to replace the old one and continue working to find a solution.
Hope to hear some good news from ASUS.

Godaemon
01-24-2013, 04:27 AM
After all these days having tried a million different things and 2 bios chip replacements.
The bottom line is that ASUS G53SW-XN1 is NOT COMPATIBLE with the above mentioned SSDs.

DO NOT BUY OCZ VERTEX 4/CORSAIR NEUTRON GTX/SAMSUNG 840 PRO SSDS if you own a G53SW-XN1.
It wont work no matter what you do.

There is a BIOS CHIP related incompatability. I cant think of something else.
The default bios chip is labeled as Winboard ..something .
When i replaced it with an MXIC 25L Series (SOIC-8) chip using the same untouched 203 BIOS the SSD works fine and the laptop is blazing fast.

I am currently using the 840 PRO 128GB Model and i boot in windows in less than 12 secs.
The only thing i lost because of the bios chip change is the illuminated keyboard but to be honest i can live with it.

I repeat :

DO NOT BUY OCZ VERTEX 4/CORSAIR NEUTRON GTX/SAMSUNG 840 PRO SSDS if you own a G53SW-XN1.

Changing the BIOS Chip voids your warranty but my laptop is already out of warranty so i was able to freely play with it and experimenting with its parts. :)

germandude
06-24-2014, 09:09 PM
I have a similar experience - I am running the Samsung 840 Series (NOT PRO!) just fine. However, it will NOT WORK with another SATA3 HD it seems. At least the following combination gives "The communication between the disk and the host failed" errors e.g. using Hard Disk Sentinel:

Samsung SSD 840 Series (250GB) and HGST HTS721010A9E630 (1TB) no matter which slot you put them together DO NOT WORK reliably in the G53SX. Any other HGST or other HD I tested worked fine but the other ones are all SATA2.

Just my report. Chatting with ASUS support explaining the above and asking specific questions about the 1TB new SATA 3 HD revealed no knowledge about any compatibility issues. Also the following statement was made by support: "Yes the 2 SATA3 disc are supported".

So Godaemon's statement above makes sense with older SATA3 devices which may work - I can confirm that here, too. And at least some newer do not - at least not reliably. The HD did work in the G53SX, but with the random and frequent communication issues above which were leading to the HD just switching off eventually (go into park) and being not accessible until reboot.

This is confirmed still to be the case with BIOS 209, the latest one per today from 2012.

SHAME ON ASUS!

Case closed for me, I am ok with the 840 SSD and the SATA2 drive.