PDA

View Full Version : G75 + SSD = big troubles



bheam
01-07-2013, 11:36 AM
Hi,

I've been trying to upgrade a G75 with a SSD. (Windows 7)

First i got a Agility2 drive that didn't detect at all. Then i returned it.

Then i got an Agility3 240GB drive that worked fine for 5 months, but sometimes computer wouldn't boot. Eventually it wouldn't boot at all. Attempting to reinstall windows yielded the same result. Then i ordered a replacement.

Then i got another Agility3 240GB. This one wouldn't install windows, it would stop during the format phase with Error code: 0x80070057.

Then i reinstalled Windows 7 on the regular HDD that came with the G75, no problems at all.

THEN i tried the last two SSD disks (mentioned above, the agility 3 240gb ones) in another computer (an old dell inspiron) and they worked with no problems at all!

I had latest ssd firmware (2.25?), and latest g75 bios (222?).

I tried calling ASUS support, but all i got was that SSD drives are not an official replacement part for asus computers so i'm sol.

Any tips?

Myk SilentShadow
01-07-2013, 12:01 PM
Quick fire question, when you installed Windows...did you leave the HDD connected or disconnected?

finalhour
01-07-2013, 02:12 PM
Hi,

I've been trying to upgrade a G75 with a SSD. (Windows 7)

First i got a Agility2 drive that didn't detect at all. Then i returned it.

Then i got an Agility3 240GB drive that worked fine for 5 months, but sometimes computer wouldn't boot. Eventually it wouldn't boot at all. Attempting to reinstall windows yielded the same result. Then i ordered a replacement.

Then i got another Agility3 240GB. This one wouldn't install windows, it would stop during the format phase with Error code: 0x80070057.

Then i reinstalled Windows 7 on the regular HDD that came with the G75, no problems at all.

THEN i tried the last two SSD disks (mentioned above, the agility 3 240gb ones) in another computer (an old dell inspiron) and they worked with no problems at all!

I had latest ssd firmware (2.25?), and latest g75 bios (222?).

I tried calling ASUS support, but all i got was that SSD drives are not an official replacement part for asus computers so i'm sol.

Any tips?

Did you do any searching on here about SSD + G75? Most of us all have SSD's installed and there are great guides to doing so. I'm not sure if you just chose drives that are incompatible, had products that were faulty, or did something wrong but the G75 is not inherently flawed and plays quite nice with SSD....

john_from_ohio
01-07-2013, 02:22 PM
Hi,

I've been trying to upgrade a G75 with a SSD. (Windows 7)

First i got a Agility2 drive that didn't detect at all. Then i returned it.



Try any of the intel 520 series or Sammy 830 series. Samsung also has 840 series out ( cheaper / supposedly shorter life time but probably not a big worry for any of us ).

Personally I would go Intel ... my G75's been working fine since last May running on Intel 520 180 gb ssd plus 1 TB secondary drive.

ledgedes
01-07-2013, 08:40 PM
I had the same problem with my G75, Even did a 'clean' install of OS, but same problem!!!! Agility sent me a New SSD, same prob, so I went with the Intel, works Perfectly!

Pitcher@asus
01-08-2013, 04:03 AM
please saw the http://rog.asus.com/forum/showthread.php?27051-ASUS-G75VW-Clean-Install-Guide&country=&status=

tkolarik
01-08-2013, 04:26 AM
I have an Intel 520 and never had a problem with it. Just can't install Windows on it with the 2nd HD bay populated, put it in after the basic install.

I went with Intel for the 5 year warranty!

rewben
01-08-2013, 04:53 AM
i have tried intel 520, samsung 830, fujitsu oem ssd, ocz vertex 3 and 4; none of them failed on me.

(coming up are samsung 840 pro and 840)

edit: when i searched forum about agility drives, the results were inconsistent; some reported issues, while some had no problem.

Alude904
01-08-2013, 10:33 AM
I would try one of the previously mentioned brands. Intel, or ocz.

rewben
01-08-2013, 11:34 AM
@Alude904, for performance and reliability, i suggest you go for intel 520 or samsung 840 pro.

finalhour
01-08-2013, 04:48 PM
I have 0 problems with my Corsair Force GT

Paulovrv
01-08-2013, 10:07 PM
No problems here with kingston hyperX 3k 120Gb. And this is very cheap!

bheam
01-11-2013, 09:10 AM
Well, to add to this - I have 3 of these laptops (G75). The drives work on one of them, and doesn't work on the other two - so something must be different with the computers?