PDA

View Full Version : G75 with SSD and wireless card



ben02
01-10-2013, 01:54 AM
Hi guys, any advice is appreciated.
Does anyone have experience about which SSD works well or badly with a G75 G75VW-DS71? My first time getting a SSD, shooting for about 128GB.
Also for wifi cards, is the default card good enough or should I upgrade it? If so, any particular card to consider or avoid? (Wifi here is really busy and dies sometimes, I dunno if a better wireless card can help.) Thanks!!

rewben
01-10-2013, 02:10 AM
1. there are many good ssds; my preferences are samsung 840 pro, intel 520, plextor m5p, crucial m4. get 240-256gb if possible (higher performance yields than 120-128gb)

2. i am ok with the default wifi card (i use ethernet most of the times); but to many its performance are considered bad. the compatible ones with bluetooth that i know of are intel 6235 and bigfoot killer wireless-n 1202.

edit: sorry i forgot; for wifi card, a better alternative is to use usb wireless dongle.

Pitcher@asus
01-10-2013, 02:10 AM
did you meet any problem or just want to upgrade device?

ben02
01-10-2013, 03:54 PM
No problems, just upgrade :) Although the wifi connection could be better (again, not sure if it's related to the laptop or not).
1. Yeah I really liked Samsung 840 Pro but I heard its TRIM isn't great. And you convinced me to get the 256GB.
2. I admit I know nothing about laptop Bluetooth so I dunno if I ever use it. Why is wireless USB adapter better than a new wireless card? Which model do you use, or what's good/bad?

One quick question, anyone know what the factory/default wifi card is in a G75VW-DS71?

Thanks for the info guys!

Quasimodem
01-10-2013, 10:27 PM
If you want Bluetooth, Intel 6235, if not, Intel 6300 or check out Killer-N

ben02
01-11-2013, 02:44 AM
A super helpful thread: http://rog.asus.com/forum/showthread.php?22850-Wireless-internet-drops-randomly
Apparently G75 laptops have Atheros cards? Hmmm.
I'll probably switch to the Intel 6235 you guys are talking about. But what's this I hear about the new Bluetooth possibly acting weird after installing the Intel?