View Full Version : ROG GameFirst II

01-12-2013, 02:10 PM
I get a "Run" prompt dialog box as soon ask my desktop loads with this software, rather than auto-loading without it like GPU Tweak. What is the difference in the startup of these applications?

Might I need to set the ROG GameFirst II software to run as an Administrator so that I don't get prompted at startup?

01-13-2013, 09:12 AM
You can try this:
1. Uninstall the application.
2.Restart Windows.
3.Right click the setup application.
4.Go to properties.
5.Go to Compatibility TAB and choose Change settings for all Users.
6.Choose Run as administrator and then Apply.
7.Close Properties pressing OK.
8.Right click the Setup application again, go to Run as Administrator and do the installation.
9.After the installation has finished, locate the .exe file of the installed application. If you cannot, go to the shortcut on your desktop
right click and choose Go to target file location.
10.Locate the file of the application and repeat steps 3 to 7 for the installed application.
11.Restart your computer and see if it's OK.
If this doesn't work, you can latter change the security permissions of the application, but first please try the above steps first.

01-13-2013, 04:11 PM
Done, and it works. Thanks nikosa43, that's very helpful.

01-13-2013, 05:10 PM
I'm happy to hear good news. Enjoy.

01-13-2013, 06:05 PM
Is there any setup required for the GameFirst II software?

Or does it automatically recognize games like BF3.exe and VoIP programs and set them as a high priority for LAN traffice as soon as they are launched?

01-13-2013, 11:43 PM
LOL. To be honest i haven't used it. i'm not gaming so much online. You have to search the settings under Games TAB. It suppose to give priority to Game Data Traffic when you play online and the same time you download something, (let's say with some Torrent client, wich usually suck the blood of your bandwith).

02-06-2013, 05:59 PM
i updated my Maximus V Formula bios from 1408 to 1404 and then it said that i had to update ROG GameFirst II, so i just updated GameFirst II from the version i got on a disk with the motherboard to version 9.00.2020, but now it says that i only can use it for 30 days before i have to buy it. have i done something wrong or do you have to buy it?

12-16-2013, 09:47 PM
I have tried this but I still get the pop up when I first boot up....Please help

12-17-2013, 09:28 AM

This is really annoying me now - I am thinking about just uninstalling it and forgetting about it

12-18-2013, 09:12 AM
wow the support on here is about as good as this dump Impact Mobo I bought..

12-18-2013, 03:14 PM
Now I cant get Sonic Radar to work in BF4.


12-21-2013, 02:13 PM
I receive the update available warning and the link directs me to this: http://www.cfos.de/en/download/download.htm?reg-8.03.1983-asus&upd=r&__ntrack_pv=1
I've downloaded but when I'm going to install it, it says that I'll install a trial version instead of mine current version, if I'm sure to do it.
Is the GameFirst II not a version that can be update automatically? Is this right?

01-03-2014, 07:51 PM
Correct, do not download the update from cfos. It's rather annoying that it constantly pops up, there SHOULD be a way to disable it but cfos says it's on ASUS and ASUS says it's on cfos so...

01-03-2014, 09:32 PM
@crazymilk. Why the **** would you expect anybody's help?

a. This thread is ancient, and you "necroed" it
b. you are using a very impolite tone, and are defaming Asus' product for your own shortcoming

I'm sorry for the language, but seriously?