PDA

View Full Version : G55 Windows 8 upgrade display issue



Kamil
01-15-2013, 03:44 AM
I just upgraded my G55VW to Windows 8 (I legitimately like a lot of the changes) and all of a sudden it cannot seem to understand the graphics card or monitors that are in use. Speccy and the Display control panel both list only one monitor named "SMC23A750X" with a resolution of 1024x768 and refresh rate of 64Hz, with the graphics being provided by Microsoft Basic Display Adapter. NONE of those things should be correct, considering I have the built-in monitor and an external one, both with resolutions of 1920x1080, refresh rates of 60Hz, and the graphics should be provided by the GTX660M that's installed.

So far I've tried reinstalling the latest graphics driver listed on the ASUS downloads page, which resulted in the whole system crashing to the point where it had to go to a restore point created when Windows 8 was installed, and installing the latest driver provided by Nvidia, which did nothing noticeable. Presumably I wouldn't be able to get past the "checking for hardware compatibility" stage if the OS actually couldn't find the card, but it certainly doesn't want me to use it.

rewben
01-15-2013, 05:37 AM
did you follow the steps highlighted in the driver download page at ASUS support page (http://support.asus.com/download.aspx?SLanguage=en&p=3&m=G55VW) (i.e. to upgrade your nvidia driver first in w7 environment before the OS upgrade?)

if not, you can try
1. uninstall the existing nvidia driver; reboot;
2. run the nvidia driver from ASUS or geforce.com (make sure you choose the notebook version), use custom install, and check the box that allows you to perform a clean install.

15916

15917

Kamil
01-15-2013, 06:10 AM
Uninstalling doesn't work, as in the drivers show up in the "uninstall a program" menu, but double clicking or right clicking and selecting "uninstall" both do nothing, and there was no uninstall application in the NVIDIA Corporation folder (or subfolders) in Program Files.

And yes, I completely uninstalled all my Nvidia drivers in Windows 7, installed the latest drivers on the Downloads page, and THEN upgraded to Windows 8 (though there were several weeks between those last two steps).

Pitcher@asus
01-15-2013, 06:27 AM
strange, can not uninstall? could you into save mode to uninstall and install again?

rewben
01-15-2013, 09:42 AM
that's indeed very weird; normally double-clicking the components will start the uninstall.

i suspect the upgrade was partially successful. can you run as administrator's prompt (press win key + x and choose 'command prompt (admin)') the command 'sfc /scannow' first; reboot; then try to install the nvidia drivers again?

Kamil
01-15-2013, 05:17 PM
The prompt started a verification step, and when it reached 100% it said something along the lines of "No problems found." I didn't memorize exactly what it said, but it didn't do anything after that. I rebooted and still can't uninstall the old drivers. I haven't tried just installing new drivers since then.

By the way, if nothing else works I plan to just click that convenient "Remove everything and reinstall windows" button. Most of what I care about is online anyway, so I'd just need to move a few files to cloud storage. I mean, that's not IDEAL since I'll need to spend a pretty good amount of time getting all my software installed again, but that's better than what's going on right now.

Kamil
01-15-2013, 09:02 PM
Deleting everything and reinstalling the OS and drivers worked. It also fixed another weird issue I had where the power menu did not include a sleep option.

I'll be spending the next week or so getting all my software back, but at least the computer is usable now.

rewben
01-16-2013, 01:15 AM
good to hear that :)

Pitcher@asus
01-17-2013, 05:25 AM
so the problem is slove?

rewben
01-17-2013, 05:27 AM
yes, Mike.