PDA

View Full Version : 5-40 FPS Improvement... True Story



dparish2
01-17-2013, 06:32 PM
Easy change that made a huge improvement to my FPS, I'm on a stock G75VW, i7 3630QM, and stock 660m speeds with Windows 8.

So I loaded F.E.A.R. the other day and couldn't figure out why I was only getting 28-34 FPS no matter the settings. There were some other disappointing games too like how Hitman Absolution and Crysis 2 ran. I remembered reading something about how disabling HID devices helped in FPS, so I tried it...... BAM!!!!

ALL 1080p
F.E.A.R. constant 60 FPS with VSYNC on High Settings
Crysis 2 noticable 7-11 FPS improvement Im ususally always in the 40s on "very high" DX11 ENABLED as well as High Res Textures w/ other adjustments
Sniper Elite V2 Ultra settings w/ some tweeks 50-60 FPS
Hitman Absolution is running upwardsof 60 FPS w/ some tweeks, I could hardly get out of 30-40s before with lower resolution

What I did was go to Device Manager and HID, I disabed all my HID keyboards, and my mouse. MAKE SURE YOU CHECK PROPERTIES of what they are, took me forever to realize that FN+F2 is a HID device and I disabled it. Hope this can help some people

xeromist
01-17-2013, 09:08 PM
You might try re-enabling them one at a time. I had the same problem on a desktop computer and it turned out to only be one of the devices that was causing the issue and the rest worked fine.

WontonNoodle
01-17-2013, 10:48 PM
if you disable your HID mouse and keyboard how do you play the game?

dparish2
01-17-2013, 11:19 PM
My mouse and keyboard work just fine, I have had ZERO issues with any input device after I did that.

WontonNoodle
01-18-2013, 01:12 AM
So you disabled HID under device manager and your external keyboards/mice still works?

Silverkid
01-18-2013, 02:09 AM
Could you please share more info about this? for example, what are the names of the devices that you disabled?

dparish2
01-18-2013, 03:21 AM
1. Yes no problems with any device

2. Under Device Manager and "Human Interface Devices" drop down you will see your HID devices, I have a Logitech Mouse, Microsoft mouse, Steel Series keyboard and Wifi toggle switch (dont disable that or fn+f2 wont work) I right clicked the devices on the drop down and hit disable. I have no Idea why this works but it does.

dparish2
01-18-2013, 03:31 AM
16041 This is my only HID device now.

Ricky
01-18-2013, 12:09 PM
1. Yes no problems with any device

2. Under Device Manager and "Human Interface Devices" drop down you will see your HID devices, I have a Logitech Mouse, Microsoft mouse, Steel Series keyboard and Wifi toggle switch (dont disable that or fn+f2 wont work) I right clicked the devices on the drop down and hit disable. I have no Idea why this works but it does.

I try do step by step like you tell but my Toro wireless mouse is not function

TenBlade
01-18-2013, 02:54 PM
There´s a good thread on the issue here http://forums.steampowered.com/forums/archive/index.php/t-1279444.html
Very interesting find, anyhow.

srmojuze
01-18-2013, 05:29 PM
I am not noticing any issues with HID on my G55 Windows 8. But anyway I will post a Hawken tweak guide with FPS results and you all can tell me if you are encountering any better/worse performance.

Ricky
01-18-2013, 11:48 PM
There´s a good thread on the issue here http://forums.steampowered.com/forums/archive/index.php/t-1279444.html
Very interesting find, anyhow.

I think this issue for Logitech device only

xeromist
01-18-2013, 11:58 PM
I think this issue for Logitech device only

+1 when I had this issue it was Logitech.

Belenos
01-21-2013, 10:31 PM
Mmmh... disabling HID is not the best option if the only HID shown is my Logitech mouse. I need that somehow ;-}

srmojuze
01-22-2013, 03:36 AM
True Story... LOL

16200