PDA

View Full Version : Clean win7 install on G74Sx - HDMI port not detected



Spook50
01-18-2013, 06:40 AM
After owning my G74Sx for just over a year, I decided to do a complete reformat and reinstall of Win7 (no problems really. Just routine maintenance/cleanup). After installing the latest GeForce drivers and what I presume to be the latest Realtek drivers, neither Windows's audio control panel nor Nvidia's control panel see an HDMI port in my system. My unerstanding is that the Realtek HDMI-specific driver is made for ATI video chipsets and shouldn't be necessary for Nvidia based systems (correct me if I'm wrong please).

Is there another driver somewhere or a setting that I may have overlooked? I frequently connect my laptop to my theater system (big screen and surround is pretty much mandatory for Skyrim, ha), so HDMI functionality is a pretty important aspect to my system. Thoughts?

GeForce 560M video chipset too BTW.

indianacarnie
01-18-2013, 01:19 PM
Not 100% sure this would/will apply to you but I just did the same thing. Clean install of 7 on my G74Sx (new ssd). Like you , everything went perfect. I DID have to come to Asus's site to get the ATK for my keyboard backlighting. Haven't even looked at any of the ports yet to tell you the truth. Anyway....... maybe you need to go get the ATK for the port driver?

dstrakele
01-18-2013, 04:15 PM
The NVIDIA driver controls HDMI port audio and video on the G74SX. You might try reinstalling the NVIDIA driver from Windows Safe Mode using a 'clean' install (launch the NVIDIA installer, choose "Custom Instal" and check the "Clean Installation" checkbox).

Spook50
01-18-2013, 10:32 PM
Turns out it was user error. I just had to plug it into my receiver. Plugged it in, Windows detected my receiver, set up the speaker configuration, and everything's good to go. Now when it's disconnected, it shows an available A/V output for the HDMI, but obviously grays it out as "disconnected" because, well, it is.

So chalk it up to me just getting ahead of myself.

dstrakele
01-19-2013, 02:19 AM
Go make yourself a huge Club Sandwich with LOTS of BACON!!

Pitcher@asus
01-22-2013, 05:58 AM
are you install driver from ASUS website?