PDA

View Full Version : Screensaver and Sleep do not work in G75VW



Maximko
01-22-2013, 07:44 AM
I have G75VW with Win 7 Home Premium SP1. There is a problem - the screensaver does not start and the notebook does not go to sleep mode when it has to. I disconnected all external devices (sometimes such problem is caused by certain mouse models), but there was no effect - anyway, the screensaver does not start (though it works fine if I click Preview). In my energy plan I indicate to sleep after 3 minutes when on battery. I disconnect the power supply - 3 minutes are gone, 5, 10 minutes - no sleep. With that all, I have a QIP installed (an instant messaging client), and in its settings it is indicated to change the status on "Away" if there are no user movements during 10 minutes. And it works! After 10 minutes the client icon changes as it should. But the notebook itself does not care a damn. Any ideas how to fix that?

dstrakele
01-22-2013, 12:21 PM
A similar issue is reported in http://www.sevenforums.com/general-discussion/242741-no-sleep-no-screensaver-pci-aspm-disabled-due-known-incompatibility.html. In the Power Management tab of Properties of the Wireless Network Adapter in Device Manager, many G75 users have configured to NOT allow Windows Power Management to turn off the device to save power. This configuration may prevent the laptop from achieving Sleep.

Is your Wireless Network Adapter configured in this manner?

Maximko
01-22-2013, 12:34 PM
My wireless adapter is disabled, as I use only Ethernet wired connection. However, I have checked the Power Management tab. There is an enabled option "Allow the computer to turn off this device to save power". The same option is enabled for the Ethernet adapter. So that does not seem to be the cause of the problem in my case.

dstrakele
01-22-2013, 12:46 PM
Does behavior change if you choose to turn off the display rather than run a Screensaver?

Maximko
01-22-2013, 12:51 PM
No, screensaver, dim the display, turn off the display, go to sleep - none of them works.

dstrakele
01-22-2013, 01:02 PM
I'd look at what other changes you've made to "On Battery" Power Management settings from default values.

Create a new account with the same rights, login to it, and see if it can Sleep on battery in 3 minutes.

You could also run the Power Diagnostics Report as was done in the referenced thread.

Maximko
01-22-2013, 01:38 PM
Ok, I just clicked "Restore default settings for this plan" (Balanced, that I use), and everything works fine now. I looked through all options in energy plans and I just cannot figure out which of them could affect the ability to start screensaver or to go to sleep. There are just no relevant items, if judged by their names.

Anyway, thanks a lot, dstrakele!

dstrakele
01-22-2013, 01:50 PM
Unfortunately I'm on a phone (and about to enter a Sleep state myself), so I won't be of further assistance. Hopefully, someone else can weigh in with a suggestion. If I had to guess, I'd probably choose "Minimum Processor State".

Pitcher@asus
01-23-2013, 04:21 AM
maybe you set some item, when you set back default the problem is slove.

Maximko
01-23-2013, 07:46 AM
I can bet that is right :)
The question is - which item exactly? Actually, before posting here I looked through all those items in energy plan hoping to find the solution, but there are just no options that could be related to inability to sleep or start screensaver. Therefore I could not even imagine that "restore to defaults" could help somehow.

mrc00l88
05-02-2013, 04:04 AM
I am running into this as well with mine not dimming after x mins or shutting display after x mins. Going to test more tomorrow

sjnicolo
11-24-2013, 11:41 PM
Did you get a solution, I am having the same problem and have done all the suggested steps?

X_Splinter
12-02-2013, 09:48 PM
I am also having the same problem