View Full Version : I stuffed up my BIOS update on my Asus G73JW

01-27-2013, 05:10 AM
I have an Asus G73JW laptop and I used that laptop for music audio production with Pro Tools

One of the instruction was to disable C-state transition and turbo-boost as the program does not support that. I manage to do that with Throttlestop. However one of the plugins for Pro tools, guitar rig had issues which hyperthreading where the program crash becuase of that. I was instructed to disable hyperthreading as guitar rigs and other plugins do not support that.

There was no option on BIOS or on throttlestop to disable hyperthreading and searching the internet the only way people was able to do that was through editing the bios using amibcp.

I tried to used the amibcp to reveal the hidden bios settings but since the amibcp files shows that all options were shown even though they clearly aren't showing up in the bios menu. I then just edited the hyperthreading, c-states, enhanced c-states, turbo boost to be disabled through "optimal" and "failsafe"

I flash this modded Bios and now whenever I turn on the computer. nothing appears on the monitor and the computer than automatically turns off.

I know I stuffed up somewhere in the modded bios and I knew that the program was used at my own risk but I needed to turn off hyperthreading to run a program that I will end up using regularly to work.

Well I am going to send this computer in for repair unless anyone here has any suggestion to fix this (I put in the original bios in the usb and tried to flash it like that but since nothing appears on the monitor there is no way I can reflash the bios).

However even if I do eventually send this computer for repair. Does anyone know how to disable hyperthreading safely?

01-27-2013, 11:23 AM
Why do you need to disable HT? If you are running LINUX, there are flags you can set at boot to turn HT on and off. If your program is assigning threads to the HT cores, what is the problem? It doesn't really cause it to slow down, though it may not cause it to run faster. There are a few benchmarks that slow down with HT enabled, but those are pretty artificial.

01-27-2013, 01:20 PM
I was searching on the internet why I kept getting this problem cpu= over (essentially cpu overload even though my cpu usage was around 25% in task manager) on guitar rig and found this post from someone with similar problems


The moderator on the forum suggested that Native instrument plugins do not support hyperthreading. I don't know if that's true or not but I wanted to try it out to see if it solves the problem

01-27-2013, 01:21 PM
Try holding down the CTRL-HOME key combination on startup to see if you can access BIOS Recovery. If a BIOS file exists in the root of C:, it will be flashed.

You can also try this BIOS Recovery with the BIOS file stored on a FAT32 format USB flash drive. The key is actually having some access to the BIOS on startup and properly naming the BIOS file. See http://rog.asus.com/forum/showthread.php?10273-G51JX-need-BIOS-recovery-instructions&p=70179&viewfull=1#post70179 and finish reading the thread.

01-27-2013, 01:55 PM
ok the bios recovery method.

So I got the official bios recovery file G73JwAS.205

I tried with that in the usb drive and that didn't work

The message board suggested renaming it to AMIBOOT.ROM

Although I say my USB drive flash red for a second. That didn't work and I didn't get the crisis flash

the message board had this file in there "G60JAS.bin and G60J.bin."

So I create duplicate copies of the bios file with this name G73JwAS.BIN or S73jw.bin

That didn't work either. I got the USB flashing but no crisis flash. The computer just keep on automatically turning on and off again. Am i doing this wrong? any more options?

Thanks for the suggestion anyway

01-27-2013, 07:26 PM
The G60J are for a different computer, the G60JX series, which is older and not compatible with your computer.

01-27-2013, 07:46 PM
The BIOS must be accessible for a CTRL-HOME initiated BIOS Recovery to succeed. You can try it again several times (LED activity on the flash drive is a good sign). The correct file name is important. Unfortunately, I don't know exactly what it should be, but your use of multiple names is how I would proceed.

But your laptop could be in a state where it's time to pull out the SPI Programmer (see http://rog.asus.com/forum/showthread.php?24576-G74SX-Bricked-Bios-after-update-...SOLVED!) .

01-28-2013, 03:24 AM
"The G60J are for a different computer, the G60JX series, which is older and not compatible with your computer. "

I'm not using the G60J bios. I'm reading the thread that was linked where the person rename the bios file to match the name of the system (which was the G60JX series) and they were able to reboot the system

I mention that I renamed the bios similar ways.

In any case I've tried doing all of this CTRL Home and I haven't had any luck. I have a feeling that I had to rename the file the right way but I don't know what I'm supposed to do there.

The SPI programmer may be an option if me returning the laptop for repair doesn't solve the issue

01-28-2013, 06:07 AM
damn I realised my system is out of warranty by about 20 days

01-28-2013, 08:25 AM
agree it,Try holding down the CTRL-HOME key combination on startup to see if you can access BIOS Recovery.http://www.oksky.us/imiss/images/3.gif

01-28-2013, 11:17 AM
OK, @dasilva, my mistake. I thought that you were saying you downloaded the G60JX BIOS and used that, not that you renamed in the same pattern. I don't know what I was thinking at the time I posted. Sorry about that.

02-02-2013, 09:38 AM
Unfortunately since the laptop keeps turning off automatically after a few seconds you won't gonna make it with the recovery process.

If you are still under warranty send it to ASUS.

If not , ebay is your friend


The only thing you need to do is to disassemble your laptop and find someone to solder the new chip onboard.

And Dont play with the bios :p