View Full Version : [K42F A42F Notebook] ELAN Touchpad won't work properly with AC power on

07-06-2011, 02:22 AM
Hi there, community. Bought my ASUS K42F/A42F Notebook three days ago and I'm loving it, except for one thing: When I have it plugged to AC power, the ELAN Touchpad won't respond properly to anything, but it does just fine when the notebook is working on batteries.

I tried to update drivers from ASUS website, but those were outdated (2009) and of no help at all. I'm currently running Windows 7 Home Basic x64 (came along with the notebook, genuine and everything) and I have it all updated 'till the last updates I could find.

Any feedback will be apreciated.


07-06-2011, 03:26 PM
Have you tried toggling the touchpad with the function keys after you unplug?

08-02-2011, 12:00 PM
Hi xer0 and everyone, sorry about my late reply. I was out on a trip ^^"

So yeah, I tried toggling it before/after unplugging and also before/after plugging it back, but no result.

And, thanks to my trip through Europe, I found the problem to be even weirder, because it worked perfectly while plugged to the AC power wherever I was outside Brazil.
Yep, it works just fine when it's plugged to an outlet in Spain, Germany, France or Netherlands. But now, back to Brazil, it's back to acting weird when plugged to AC power.
I wondered if it was due to voltage (since everything in Europe is 220v), so I tried using a voltage transformer, to no effect. The problem persists.

Well, at least I know it's not a driver or other software problem. It's just the power source acting funny. I'll try a couple more things (such as adding a decent ground wire) and come back with results. Don't think many other people are going through the same problem, but I'd like to keep it documented.

Thanks y'all

08-02-2011, 05:07 PM
That IS strange. I'll be interested to hear if you can find any solution.

01-03-2012, 08:12 AM
There is something to do with filtering in it's driver i guess..... Try to have good grounding. Had ever program a device and got similar problem. The device works great in many places, but fails in china, indonesia, and any particular countries with bad grounding...

Elan touchpad has many issues in other laptop brands (lenovo, acer, dell) as well. Wondering if there is a way to port it to use synaptics drivers.

04-04-2012, 06:05 AM
:( Hi... I hope you guys can help me.

whenever I plug in my headphones the speaker microphone is not automatically disabled and still catching lots of noises from the environment. Tried using different kinds of headphones thinking it's the problem but still the same. What should I do to turn off the speaker microphone? Is there a driver I could download? Please hellllllp! I will use this pc for work and any help would be much appreciated. Thanks.