View Full Version : G73jh-A2 Issue

07-06-2011, 11:19 PM
I'm new here and i have i simple question
Ive tried to update my laptop with the catalyst 11.5b
and while install the video driver i got BSOD
so i restart my laptop and delete the new driver and the whole catalyst
everything is run fine but i got a wired message from windows that
the ATI Graphics Driver have a problem.
If someone could tell me the steps I need to do to update all things to the newest versions and the order to do that i will be generous.
do I need to install Vbios -> Bios -> and then driver or in a different order??
do i need to uninstall something first?
P.S I never change or install any update till the catalyst 11.5b so all my version are like i got my computer.

thnx alot :)

07-07-2011, 03:02 AM
Make a bootable USB Flash drive formatted for FAT32 if you do not have one. (See How To Fix Your GSOD Blues thread for instructions)
Copy the 213 BIOS ROM, plus the files needed for vBIOS depending which package you are using

Update BIOS to 213
Update vBIOS to GSOD Fix release

Hit my driver page and download ATI Crap Cleaner, and run that to remove your partial AMD install.

Download 11.07 Early release from my driver page and install that package.

07-07-2011, 07:19 AM
thnx for reply...
so first of all boot from usb that have the bios and the vbios files?
than clean with ati crap remover and than install the drivers??

do i need to uninstall something before i boot from usb?
and what did u mean when u said "depending which package you are using"?


07-07-2011, 02:36 PM
There's the official vBIOS release, then I posted a modded one with Overdrive enabled

07-07-2011, 11:39 PM
I done exactly the steps you write and its work just perfect:
Bios: 213
Vbios: 93v
ATI Drivers (Catalyst): 11.07

I want to said thank you from all asus g73 owners!

keep help and share your knowledge

07-08-2011, 03:10 AM
The vBIOS was a team effort, but thank you for your praise anyway. :)

07-08-2011, 09:23 AM
I post this too soon...
i need help i did everything I write and when windows startup my asus just freeze...
what should i do?

edit: i used this thread
and update the creative drivers and the problem solved!