PDA

View Full Version : G74sx - problem with Intel Centrino Ultimate-N 633ANHMW wifi adapter - plz hlp!



0c7or0k
01-30-2013, 01:54 AM
I just installed an Intel Centrino Ultimate-N 633ANHMW wifi adapter in my Asus g74sx-a1

Windows recognizes the card, installs the most updated driver (verified), enables the card and appears, for all intents and
purposes, to be working perfectly... But the card wont work! - it wont find any networks and gives me an "unexpected
error" when I try to do anything related to managing my networks.

things Ive tried:

uninstalling/reinstalling the device & driver many times
rolling back/updating drivers - also used the tool on the intel website
deleting the adapter all together and scanning for hardware changes (which windows promptly finds the adapter, installs the
correct driver, and still wont work)

Im currently back running on my stock wifi adapter (Atheros) - which works just fine...

Please HALP!!

Pitcher@asus
01-30-2013, 02:52 AM
is it work in other computer normal? when you install complete, you can see the device post at device manager, but it can not find any ap right? did you try to disable bundle wifi adapter and network?

dstrakele
01-30-2013, 03:10 AM
As I understand it, the Atheros driver must be uninstalled and the Atheros Wireless Network Adapter device uninstalled from Device Manager BEFORE the Atheros WiFi card is physically removed from the laptop, prior to the installation of the Intel WiFi card and driver.

There is also the chance your Intel Centrino Ultimate-N 633ANHMW is DOA.

0c7or0k
01-30-2013, 03:46 AM
Ill try that - uninstall the driver, then the adapter, and go with the Intel.

@Mike Lu - yes, the compute4r works perfectly fine with the Atheros adapter; I havent tried the Intel in any other computer (dont have one)... How do I disable the bundle wifi adapter and network?

thanks for the replys! =)

dstrakele
01-30-2013, 04:55 AM
I read your PM about the ASUS Live Update error on the BIOS flash attempt. I recommend you uninstall ASUS Live Update or configure it only to notify of updates, but not install them. Several users have reported ASUS Live Update bricked their laptops when flashing a BIOS update.

Any time you flash a BIOS to your laptop, there is a chance it can render your system unusable. If you are not experiencing any problems, it is best to avoid updating the system BIOS.

I recommend reading http://forum.notebookreview.com/asus/174395-bios-update-guide-asus-notebooks . html.

For the best chance of BIOS flash success, I recommend the following:

1) Format a USB flash drive with a single FAT32 partition.

2) Download the BIOS update file from the ASUS website directly to the flash drive. It is best the BIOS update has no contact with an NTFS file system. A corrupt BIOS on a bricked laptop was reported to contain the entire NTFS directory tree. See http://forum.notebookreview.com/asus-gaming-notebook-forum/656498-g74sx-circuit-reprogram-bios-spi-print.html.

3) Uncompress the BIOS update from the downloaded container file. Note the filename, so you can select it later.

4) Restart the laptop, pressing F4 to enter the EasyFlash utility in the BIOS.

5) Select the BIOS update filename you uncompressed on the flash drive (there may be a backup BIOS file located in C: on your HDD also displayed in the list). Choose to flash your BIOS update file on the flash drive. The laptop will shut down and restart.

0c7or0k
01-30-2013, 10:30 AM
wowzers! Thanks for the tip!!

=)

burn0u7
01-30-2013, 11:07 PM
So one of my friends and I have the G74SX-DH71 we both replaced the atheros wifi/bluetooth module with an intel Centrino 6300. we both had no issues once we found the correct drivers. he didnt remove the atheros drivers before he put the new module in but I did. once the correct drivers were loaded, no issues. unless your module is DEAD or non functional, it's more than likely a driver issue which actually should be addressed over at intel's support. I seriously doubt its a support or engineering problem with the G74 itself.

I dont use the auto detect tool in intel. it has steered me wrong many times before. Sometimes Cisco and Intel arranges their descriptions of drivers in a unorganized confusing stupid way so its very easy to get the wrong driver for whatever OS you are using.

DrBeltway
02-13-2013, 06:40 AM
Glad you got the Intel adapter working properly.

It's worth mentioning that if you post on the Intel support forum or contact Intel for support and mention you upgraded your WiFi adapter yourself, they'll only say "We don't support end-user adapter upgrades".

Just FYI...

Also, you can bookmark Intel's driver listing page for your adapter once you find it so you don't have to deal with the auto-detect tool or the search.