View Full Version : g75 usb drivers

01-30-2013, 02:08 PM
Asus live update killed my usb drivers. None of my ports work anymore. I have tried the asus website to download the newest drivers but that didnt work. I tried my Asus cd that came with the laptop but them drivers didnt work. I have tried to roll back the drivers but nothing. Im on a one way trip to a full wipe soon.

What the hell is going on?

Intel(R) 7 Series/C216 Chipset Family USB Enhanced Host Controller - 1E26
Intel(R) USB 3.0 eXtensible Host Controller

This is what i need but nothing seems to work. Any ideas?

01-30-2013, 02:41 PM
maybe uninstall usb charger+ could help (http://rog.asus.com/forum/showthread.php?16217-Live-update-killed-my-USB-ports&p=213869&viewfull=1#post213869). a fresh install is a good idea, too :)

01-30-2013, 02:45 PM
I uninstalled the drivers in device manager, restarted. Download the new drivers in link and restarted again... Still nothing.

01-30-2013, 02:49 PM
HAH yes back to gaming again. Was the dam usb charger somehow. Deleted them all again with the changer and boom mouse works again!


01-30-2013, 02:51 PM
nice :) have fun!

01-30-2013, 03:17 PM
If you are running Windows 8 checkout this link. It solved all of my USB issues. http://plugable.com/2012/12/01/windows-8-and-intel-usb-3-0-host-controllers

01-30-2013, 03:36 PM
a good find, @SteveK. after a few times visiting intel's discussion forum, i gave up and didn't bother to look for this hack again.

edited: it worked.


01-30-2013, 05:15 PM
Uninstalling from Device manager will not work and will cause lots of headaches, you have to uninstall from Control Panel- program and features. I had to do this twice with reboots in between, also uninstall Asus Charger Plus, Installed the Intel USB 3.0 drivers, reboot twice, then installed the Charger plus if you need it again complete reboot twice. I don't know what but rebooting twice between uninstall and reinstall works for some of us. This procedure works for Win 7, Win 8 uses the native Microsoft USB 3.0 driver

01-31-2013, 03:43 AM
if any way can not help you, do you have press F9 to restore, if yes, the problem still occur?