PDA

View Full Version : Extreme frame drops in Crysis®3 BETA



AlexTheRepublican
01-30-2013, 06:03 PM
Hello, ROG masters! Today I had the visual feast of the well known Crysis®3 BETA (http://store.origin.com/store/eaemea/en_IE/html/originweb/demos/pbPage.demos-en_IE/). Just when I entered the game I had an enormous fps drop and after 5 seconds flawless 60 fps experience, but only for like 3 seconds, this repeating over and over. My 2013 G55 has a GTX 660M and i7-3630QM, also my laptop was set on Performance. What could it be? I can hardly say that the game was playable, causing losses after losses. I have the latest BETA driver and the Graphics were set on Medium, V-Sync off and by the way, I was not playing with the AC adapter inserted. Any ideas, Republicans?

dstrakele
01-30-2013, 06:08 PM
Insert the A/C Adapter....

AlexTheRepublican
01-30-2013, 06:16 PM
OK, bud. Thanks! My battery is so amazing that it lasts 3 hours on gaming :D. I'll keep you in touch when I got the results ;)

GottiBoi55
01-30-2013, 06:24 PM
OK, bud. Thanks! My battery is so amazing that it lasts 3 hours on gaming :D. I'll keep you in touch when I got the results ;)

You should always use "A/C power" on most graphic intensive games, such as "Crysis3".
LOL, you could play games on battery like "Angry Birds", or "Solitaire"!

PS: Here's another thread about this>>>>>Playing games in battery mode (http://rog.asus.com/forum/showthread.php?18930-G75VW-playing-games-in-battery-mode)

dstrakele
01-30-2013, 06:27 PM
http://rog.asus.com/forum/showthread.php?28033-Asus-g75vw-bad-gaming-performance is one of the more recent threads that pop up every 2 weeks discussing battery vs. plugged-in gaming performance.

AlexTheRepublican
01-30-2013, 06:36 PM
Yeah, man. Thanks for the very helpful advice, but anyway sooner or later I would have found that out too. So with the A/C adapter on Medium -- flawless experience, 60 fps smooth everything (you got the point). Cya later, master!

AlexTheRepublican
01-30-2013, 06:38 PM
Hi, Gotti. I heard that the G75 has that problem, not the G55. My friend has a G75 and always complains about it :P!

GottiBoi55
01-30-2013, 06:46 PM
Hi, Gotti. I heard that the G75 has that problem, not the G55. My friend has a G75 and always complains about it :P!

You welcome!
Yeah some have the prob, and some don't, the ones that don't are OCing there rigs with mods.

AlexTheRepublican
01-30-2013, 06:58 PM
True that, true that hehe ;). Yeah totally agree, ROG bro

GottiBoi55
01-30-2013, 07:08 PM
Yeah!
Hope that shed some light on the subject mi amigo?

SubmersedHollow
01-30-2013, 07:22 PM
what kind of settings did u used ingame? to gain 60fps?
Sorry i missread "medium" :D Sorry again :P btw what resolution?

GottiBoi55
01-30-2013, 07:45 PM
well in BF3, and MOHWF I use auto settings.
It give me ultra for texture, and all the rest are set to medium with no Vsync.

How's that Crysis3 beta, I can't wait to get my hands on the new "composite bow"
I haven't downloaded it yet!

srmojuze
01-31-2013, 02:19 AM
Yeah, man. Thanks for the very helpful advice, but anyway sooner or later I would have found that out too. So with the A/C adapter on Medium -- flawless experience, 60 fps smooth everything (you got the point). Cya later, master!

Turn your settings to High :)