View Full Version : ASUS G75VW Audio Driver Problem

01-30-2013, 06:35 PM
Hello, i just received a new ASUS G75VW laptop, and I updated the audio drivers because i heard that some people had audio issues. well, the audio driver will not install correctly. and i can't seem to get the original to install from the driver disc either. i remove the previous driver, restart, install the new one, it seems to install correctly, i restart, then when my computer boots back up, in the task bar it pops up, "The device driver did not install correctly."

At that point, none of my audio works. There is an icon that says "Via HD Vdeck" but it will not open, no error message or anything, and there used to be "Via HD Adeck" as well, that gave me a message saying something like "Incorrect OS version, please reinstall driver", but that doesn't even show up at all anymore. I have Windows 7 Home Premium 64bit, and have tried installing drivers directly from the Asus website, and other versions, none of them will work. Currently i've managed to use some sort of stock audio driver, the front speakers work (sound off though..) but the subwoofer doesn't, and everything worked when i first recieved the laptop.

So, I'm not quite sure what to do next. I've searched but haven't found someone having the same issue that I have. I think its probably more a Windows 7 problem, or Via Driver problem, but I hope someone here will be able to help me. Thanks very much!

01-30-2013, 07:23 PM
Try doing a "system restore" to a point before the update.
That should work!

01-30-2013, 09:38 PM
you could try a program called driversweeper, and only select the box that has to do with your audio drivers.
this should completely clean them off your system after a reboot.
then when trying to install the new drivers, right click and click run as administrator.
Dunno if it will work, but worth a shot.

01-31-2013, 03:14 AM
are you download form ASUS support site? could you provide more detial.

01-31-2013, 07:38 AM
and have tried installing drivers directly from the Asus website

01-31-2013, 06:08 PM
I did install drivers directly from the official website, and tried other sites as well just in case. There is a chance i'm looking at the wrong spot, if someone wants to directly link the Via drivers for G75VW then I can double check. The system restore didn't work sadly because one of the first things I did was update drivers before it was set up. (learned my lesson there...) Drivesweeper didn't seem to work either.

01-31-2013, 06:29 PM
can you write down what driver did you use ?

02-01-2013, 04:30 AM
Version V6.0.01.10600
Description Via Audio Driver
File Size
131,21 (MBytes)

02-01-2013, 06:12 PM
Still no luck... any ideas anyone?

02-01-2013, 06:51 PM
Reinstall your OS, that should work ! :p

02-05-2013, 04:42 PM
So, reinstalling my OS is my only option?

02-05-2013, 08:41 PM
This just happened to me also. I was just about done setting my new lappy up and boom the via driver just crashed. No sound. had to do a restore to fix problem. Couldn't even reinstall drivers as the system had no audio at all.

02-05-2013, 09:08 PM
I'm not sure if you are thinking 'recovery' instead of (system restore), but system restore lets you set your system back to an earlier time instead of the factory new condition like after a 'recovery'.
You may not have a lot of restore points if you just got it, but check under Start/All Programs/Accessories/System Tools to find System Restore if you want to try it as GottiBoi55 suggested.

Also, as far as drivers go, imho it's safer to stick to the ASUS download site for your notebook drivers since updated third party drivers for your notebook from the component hardware manufacturer (like Via for audio) or from the optional Windows updates can cause problems if ASUS has not approved them for your notebook.

You may want to try those unapproved drivers if you want to solve an issue, but just be aware of the possibility they could cause problems too. It's also a good idea to create a system restore point before trying those updated drivers.

Try doing a "system restore" to a point before the update.
That should work!