PDA

View Full Version : G73JH-A1 graphics issue



Loki
07-07-2011, 08:50 PM
Hi all first post here so if i miss vital information let me know and i'll post.

Had my laptop for almost a year and love it pieces however a month a go i started to get crashes with the screen going green or blue with black vertical strips. I tried updating the graphics drivers and this didn't solve the issue so I rma it. They said they replaced the VGA card and upgrade both the bios and vbios and returned it. I use the laptop for playing games and the driver that it was returned with wasn't compatable with the games i play FFXIV for instance so i downloaded and tried to install 11.6 which promptly BSOD on me so i went back and tried various other drivers. 10.10 worked so i booted up FFXIV and with in 2 mins i was crashing again with vertical stips or to a completely black screen. Again RMA this time they said my driver wasn't compatible so they reinstalled to base again and sent it back.

So to sum up I either have a working system that can't play the games i like or i try upgrading to better drivers and get to play games for a few mins before my system freezes. Any and all suggestions greatly appriciated.

xeromist
07-07-2011, 08:56 PM
You may want to review the stickied threads in this forum by Chastity. Specifically I would look at the one regarding VBIOS.
http://www.asusrog.com/forums/showthread.php?519-G73Jh-GSOD-Vbios-Update

Loki
07-07-2011, 09:50 PM
ok done the upgrade. A tentative hurray! so far so good, now just a shame that they said they upgraded the vBios both times I RMA but the link above seems to have fixed the issue.

Thanks xeromist and Chastity