View Full Version : G73sw won't charge, no power light

02-01-2013, 06:33 PM
So I just purchased a used Asus G73sw. Looked it over, turned it on tested pretty much everything (except charging) so I thought it was a decent deal. Brought it home and plugged it in and turned it on and I noticed that the Windows battery icon didn't show that it was charging. Looked at the lights on the front of the laptop and the battery icon light was off. I double checked that the power brick was plugged in, yup green light on the brick. Pulled the cable out of the laptop, blew out the cable end and the DC jack connector to make sure there was no dust, plugged it back in and nothing. So I thought there might be a short somewhere or something so I pulled the battery out, opend the laptop up, pulled out the RAM and HDD, held the power button down for 45 seconds, put everything back in and plugged the cable back in. Still nothing. I even tried plugging it in without the battery in and tried powering it up, nothing. My buddy has a G73jh so I tried his power cable and still nothing.

I'm out of ideas of what to try, anybody have any suggestions? Did I overlook anything?

02-01-2013, 07:00 PM
When you say you did this and did that, "but still nothing". Do you mean the laptop fails to start, or just the battery LED is out?

Does the battery actually charge, even though the battery LED is out?

02-01-2013, 07:14 PM
Sorry I should be more clear. The laptop starts up fine with the battery in as it runs off the battery, but the battery light on the front of the laptop does not light up no matter what I did and in Windows the battery icon shows that it's running off the battery and not charging. Hope that makes sense.

02-01-2013, 07:43 PM
Check to make sure the pin is still in the socket in the laptop. If that is broken you won't be able to charge. Also try GENTLY tweaking the power connection to one direction at a time to see if perhaps there is a loose connection.

02-01-2013, 08:16 PM
I slowly moved the power connector around and it seems to randomly light the battery light up, also Windows will show that the battery is charging at the same time so looks like it might be the connector. I just took the laptop apart and looked at the contact points on the motherboard whrre the DC jack is soldered on and it looks like an amatuer soldered it. Should have taken a pic (laptop is put back together now) but it's pretty messy, sure looks like the person I bought it from had this issue before and soldered the DC jack themselves. I'm tempted to RMA with Asus (it's still under warranty) but I might take it to a repair place to see how much it would cost to fix the DC jack.

02-01-2013, 08:21 PM
Well at least you know what the problem is now. I wish you luck with the fix! :)

02-01-2013, 08:22 PM
Thanks, and thanks xeromist and dstrakele for your help!

02-01-2013, 08:35 PM
Having this same issue with my G73jh. I'm going to try a different AC charger first, but I'm pretty positive the connector is about to go kaput on me.

02-01-2013, 08:37 PM
I'm going to try and take it to a PC repair store later today, I'll let you know if replacing the DC jack fixes the issue.

02-01-2013, 08:38 PM
Best of luck!

02-03-2013, 06:34 AM
Good luck!

02-09-2013, 01:53 AM
Just an update to my situation. The laptop repair place called me yesterday and told me it looks like the previous owner of the laptop tried to solder on a new connector, but did a terrible job and actually ruined that part of the board (which was my conclusion based on looking at it) so they had to jumper the power connector to the board. When all was said and done it works perfectly now though of course I'm out some money. This reinforces my original conclusion that had I RMA'd it with Asus, I would surely be paying them some money to fix it.

Lesson: buyer beware when purchasing a used laptop (or any electronic device for that matter).

02-11-2013, 04:49 AM
Too true. Sometimes you can get a great deal but you just never know.

Glad it's working again without a complete mainboard replacement though. I have a feeling that's what ASUS would have wanted to do because they don't generally do special workarounds that are not to specification.