View Full Version : Connecting the G75VW to a TV via HDMI

02-03-2013, 01:39 AM
I have an issue, I'm connected to the TV with my ASUS G75VW using a WireLogic RUBY HDMI cable. Picture comes through,
but the sound is on my laptop. I know this should be as simple as show hidden audio devices and click the proper HD Audio output, but nothing shows up past my laptop speakers and S/PDIF Out. I've tried:

- uninstalling/reinstalling my sound drivers, no success
- enabling hidden devices in the Device Manager and through cmd. More devices pop up, but my HDMI Audio/TV is not one
of them, even though it is clearly connected and functioning.
- Enabling Hidden/disabled devices in the Sound Manager. The only things that show up are Speakers(Laptop setting), S/PDIF Out(does nothing due to me not having anything that hooks up to this setting). and nothing else appears, as I have already
mentioned above.
- searching hours of forums and help sites including ASUS forums/support, and Microsoft forums/support

I'm running Windows 8, and am thinking the crappy OS is the problem. All of my XP and Win 7 computers work fine through
both of my LG TVs. The TV I am currently trying to run through is a 42" LG 1080p LCD TV. The Laptop supports the res, just
no audio showing up. Its a real bother. Specs as follows:

- Intel Core i7 3630QM Quad-Core (8 Thread) @ 2.40 GHz
- nVidia GTX660 Mobile Graphics 2Gb GDDR5 VRAM
- VIA HD Audio (Some generic crap I believe, needs an upgrade)
- 12.0 Gb DDR3 RAM @ 1600MHz
- Windows 8 64-bit
- 750 Gb HDD @ 7200 RPM
- Microsoft Wireless 6000 Series Mouse
- 42" 1080p LG TV @ 60 Hz/17" Laptop screen @ 60 Hz
- 6x Blu-Ray Reader/DVD Writer
- Windows XBox 360 Wired Game Controller

I don't think I left anything out. I think the G75 is on an Intel HM77 Chipset, but I could be wrong about that one.

Anyway, if anyone knows anything about how to get the sound to run through the TV, I'd be much obliged if you'd let me
know. So frustrating trying to figure out work-arounds and with absolutely no success.

The TV shows up as Generic PnP Monitor.

02-03-2013, 11:40 AM
Right-click on sound icon in system tray, choose Playback Devices. I'm sure you've done this but you're sure there's no "Nvidia HDMI output" shown there? If so then right click and choose Set As Default Device.

02-04-2013, 12:55 PM
Yeah, I've tried going in to Playback at least 2 dozen times in between and during the cmd and Device Manager sessions. It isn't appearing there for some reason. If I could figure out how to make the HDMI appear in the playback I'd be golden. I've already got show hidden and show disabled ticked, and I've tried overriding ghosted devices with the cmd interface. No luck with it at all. I recently tried it on another TV as well ( 55" 1080p LG 3D LED @ 120 Hz) and the exact same issue is at hand, just no option for it. Normally on Windows 7 with my old laptop I would simply, as you said, go into playback tick the show disabled/disconnected devices and it'd be there, but I have yet to be able to get anything other than Speakers and S/PDIF with my new machine running Windows 8. :/ I dunno if its the brand or what, but LG says it should work no problems. And besides, every other computer in the house connects sound and video, its just mine being a nuisance.

02-04-2013, 06:33 PM
What usually works for me is to turn tv on first. Plug in HDMI cable to laptop and tv. Turn on laptop. HDMI works great then.

But if you have the laptop on first then plug in the hdmi cable to the tv all hell breaks loose and nothing works right. :mad:

02-04-2013, 10:28 PM
So, I tried a few configurations like the one you mentioned above before, but I tried this one in particular and a few others, still no success unfortunately :/

I simply cannot get the HDMI Audio or nVidia HDMI to apear in the Audio Playback devices for whatever reason.

Any other suggestions? :/

02-05-2013, 01:16 PM
Your comment "The TV shows up as Generic PnP Monitor. " is troubling. Are you using the Asus provided Nvidia drivers? Did your laptop come with Windows 8 pre-installed?

02-05-2013, 03:21 PM
Yep, Windows 8 was the only one the store had left, otherwise I would've gone with and stuck with Windows 7. To the best of my knowledge the drivers are from ASUSTek's site for this specific computer, but I'm not positive as I have done a fewupdates since and don't recall if I've done them from ASUS or nVidia itself. But the Generic thing is what kinda set me off too in the Device Manager, as there is no name on the TV. It should be named like LG HD TV or something.

I'm gonna give uninstalling/re-installing the drivers a go. I've already done so with the audio drivers, but not the Video drivers. The only thing is I am getting video no problems at all, its only the sound. Hopefully the drivers do it at any rate.

02-05-2013, 10:02 PM
So, I did a full re-install of the nVidia drivers as per ASUSTek's support page, and it worked! :D

Can't believe I didn't think to re-install the Graphics drivers considering they control the HDMI Output. Amazing what frustration can do to a person, lol.

Well, a big thanks to everyone who helped me out in resolving this issue, probably still be stuck without sound if it weren't for you all. Thanks again!

PS: The TV actually shows up as LG TV 3 now, which makes much MUCH more sense. :P I'll leave this thread up for anyone else who may have similar issue down the road. :)

02-06-2013, 03:28 AM
cool, problem solve?

02-06-2013, 07:59 AM
right.I am getting video no problems at all, its only the sound. Hopefully the drivers do it at any rate.thank you http://www.oksky.us/imiss/images/3.gif

02-06-2013, 08:11 AM
Under NVIDIA Control Panel -> Set Up Digital Audio

Is anything listed here?

Your TV should be listed. Proceed to "Open Windows Sound settings." There should be 2 devices to select.

NVIDIA HDMI Output (Port 0)
NVIDIA HDMI Output (Port 1)

Set default to one of them and check.

If you have nothing appearing there, you need to install NVIDIA 310.90 drivers, not BETA ones. The sound drivers are not linked with this, it's video drivers and Windows 8 support for HDMI Audio Output. Some have reported HDMI audio issues using certain NVIDIA drivers under Windows 8, so they would revert back to an updated manufacturer video driver, solving the problem - use this one as a last resort.

Try a different video driver as described.

Troubleshoot for new drivers:

Uninstall current ones.

Remove HDMI cable during installation of new drivers. Restart after installation. TV and input on HDMI mode, then plug HDMI to laptop.

Check HDMI Audio Ouput devices.

Your HDMI devices should now be showing.