PDA

View Full Version : Phoebus under Win 8 64bit > audiodg.exe up to 20-30% CPU usage



Xeorkzys
02-03-2013, 03:38 PM
Hello,

i have have a ASUS ROG Xonar Phoebus under Windows 8 64bit and the latest Beta Driver 3.08 (CR) installed. Once i use Xear Surround Max, Xear Living FBII or Dolby Home Theater for example, the audiodg.exe have a CPU usage of 20% to 30%. With my old Soundblaster F1nalty and the PAX Drivers i have not this Problem.

Mainboard: Asus P5Q Deluxe
CPU: Intel Core 2 Duo E8400

So the question is, what can i do? Any Idear?
And Sorry for my bad English! :-)

Thanks in Advance for your Help!!!!

WTC
02-03-2013, 04:58 PM
Could you share more info? What are you playing at that time? You're playing thru speakers or headphone? Which effects are on to be exact? Sampling rate and speaker configuration?

Xeorkzys
02-03-2013, 07:33 PM
Hallo,

this Problem occur every time when a Sound (Windows, Movie, Game, Music, Youtube...) is playing. When all Sound enhancements (Xear Surround Max, Xear Living FBII, Dolby Home Theater) are disabled, the Audiodg.exe is back to normal while playing a Sound.

Samplingrate 192KHz 24Bits
Creative T7700 7.1 Soundsystem connected Analog.

Thanks for your reply!

WTC
02-03-2013, 11:24 PM
What happened if you set the sampling rate to 48K?

One thing is for sure. There is no point setting the sampling rate to anything higher than 48K if you plan to turn on any of the effects. All effects work on 44.1/48K sampling rate, so if you playing a MP3 music (which is a 44.1KHz source), for example, Windows audio system will first up-sample the audio stream to the sampling rate of your choice, and the driver will down-sample the audio stream to 44.1 or 48K Hz, apply the DSP effects, and then up-sample the audio stream back. These 3 sampling rate conversion process take CPU and gives you no benefit on audio quality. So, you may try setting the sampling rate to 44.1 or 48K Hz and turn on any of the effects. If CPU usage of Audiodg.exe is normal then you don't have a problem.

KILLER_K
02-04-2013, 02:19 AM
I used your settings, even thought nothing uses them to begin with. But got 0% cpu usage with those rate settings { 192KHz 24Bits}, plus DHT along with winamp and youtube both playing. seems to be something else causing your cpu issue. If it was me, i would do a msconfig and start disabling other programs at startup. Perhaps there or in services you will find the issue.

Xeorkzys
02-04-2013, 08:23 PM
Hello Thanks for your Help everyone!!!

The Samplerate (Upsampling) is the Problem. With 48k is it OK.

Thanks!

hingj0n
02-08-2013, 12:12 PM
The current settings that I use are 192k upsampling on 5.1 surround set with 24 bits. With Dolby H.T. and Surround Max the cpu load is mostly all of the time around 5-6% on the audiodg process. I've got an AMD Phenom II 1055t x6, I guess it's a heavy load to calculate all those sounds, especially dolby prologic.

WTC
02-08-2013, 04:18 PM
If you're interested you may try the 2 sampling rate setting: 192K and 48K, with every other settings identical, and see the difference in CPU load. With these 2 cases the only difference is the extra sampling rate conversion process for the 192K case.