View Full Version : G55 Thunderbolt issues

02-03-2013, 04:53 PM
Looks like I screwed up and got into some new tech before it was ready.. Oh well.. Here we go. Praying you guys can help me:

The computer:
G55 thunderbolt edition

The OS
Windows 8

The issue:
I have tried to connect two different thunderbolt drives to the system. A buffalo and a LaCie. Both spin up, a tone from windows says it sees it. However the drive does not show up (Yes it was formatted to NTSF via USB 3 before I tried this).

In Device manager, under STANDARD SATA AHCI CONTROLLER I am told windows cannot find enough resources to run this and I will need to disable another device in order to use it.

In other words.. IT DOESn"T WORK!!!

Any help would be great. Excited to be here.


02-03-2013, 08:27 PM
ok maybe a stupid question: are you 100% shure that your thunderbolt is thunderbolt? does it have a sticker ?

02-03-2013, 11:00 PM
Yeah, if it's truly a Thunderbolt port (and not just a display port), it'll have a white and blue sticker next to it.

02-04-2013, 06:41 AM
The problem is that some of these are advertised to have Thunderbolt, even reviews have stated taht as well, but it was always mistaken for the Display Port, which is probably the same situation you're in.

02-04-2013, 10:02 AM
Yeah but if it has a sticker it should be thunderbolt...display port has a little lightning inside a square engraved above the port. And yes since July there are G55 with thunderbolt but not in all regions.Even Marshall said it. http://rog.asus.com/forum/showthread.php?17015-G55-Thunderbolt-clarification

So you most probably have a thunderbolt display...and I don't have a clue how to help you. Sorry, will look into it...but my first thought is windows 8 drivers...

02-04-2013, 03:41 PM
Sorry it took me a while to get back to you. Yes I do have the blue and white sticker. There is no doubt the system had Thunderbolt.. If it actually supports it is another thing.

So with that question answered.. Any other ideas? I'll try to screen shots soon


02-04-2013, 08:48 PM
I'm getting a code 12 in device manager every time I try to plug in a Thunderbolt Drive.. I'm curious does anyone have a G55 with Thunderbolt that is actually WORKING?!


02-04-2013, 09:53 PM
Just found this article:


Maybe the hot-plug issue hasn't been resolved. Try powering down the laptop, connect the Thunderbolt device, and then turn it on.

02-04-2013, 11:34 PM
Tried.. No go.. Spoke to asus support.. They were TERRIBLE. What country are those people in anyway?!

04-20-2013, 08:55 PM
I finally got around to using a Thunderbolt device on my G55. I bought a Blackmagic Design Mini-Recorder, and it works perfectly. I can even plug it in while the laptop is already on, and it works just fine.

Also, another way for G55 owners to know if they do indeed have a Thunderbolt port is when you look in BIOS, it has an option for allocation under Intel Thunderbolt.

Living Room Rocker
04-20-2013, 11:59 PM
I have my (G55) TB working as well. I was going to suggest checking the BIOS as well. Taz beat me to it. Just make sure it is enabled in the BIOS.

Kind regards,

Living Room Rocker

05-12-2014, 05:56 AM
Have G75VX-DS72 with Thunderbolt sticker. BIOS shows Thunderbolt. Clean Win 7 install. Thunderbolt port shows as Standard AHCI1.0 Serial ATA Controller, but device cannot find enough resources that it can use (code 12). Tried updating MEI. Installing RST. Installing Intel Thunderbolt software. Laptop will not recognize me Thunderbolt OWC Mercury Elite Pro Dual RAID.
How can I get TB to work? Is there an ASUS TB driver for the G75VX?