View Full Version : Upgrading my G53SX, SSD and ram questions.

02-10-2013, 08:48 PM
i am going to buy the ssd and ram from this link, http://www.crucial.com/upgrade/ASUS-memory/ASUS+Notebooks/G53SX-upgrades.html Do you think this is a good deal? and will they actually work in my laptop? There are two hard drive slots in my g53sx and what slot is the one that it boots from? When i put the ssd in can i boot from the ssd and run files from my hard drive? Do i need some type of transfer kit? And do i need to reinstall windows if booting from my ssd with the hard drive in the other slot?

02-15-2013, 03:20 AM
I have already done something similar. I have put the Corsair Force 3 120GB SSD inside my G53SX. I suggest you that you put it in slot 1 and from that slot move HDD to slot 2. Then I have used Ghost for transfer original system from HDD to SSD. Once I have done that everything flows perfect. It's so fast. I have not expand memory yet, 8GB is sufficient for now and also I have 640GB secondary HDD which is sufficient for me too on laptop. I hope so you will do everything right. If you need something contact me on cwija17@gmail.com.

02-15-2013, 11:25 AM
It can boot from either. Just go into the BIOS and select SATA channel #1 to be the first boot priority. SATA channel #0 is the current boot priority, because that is where the current HDD is. The SSD will work, provided that it is a 2.5" model. Also, the G53SX (which I also own-great computer :)) does not support the 12.5 mm high 1 TB drives. All SSDs and most everything else are 9.5 mm (which is standard) and are supported by the G53SX.

02-15-2013, 05:18 PM
Hi I also have a G53sx but am having tons of SSD issues. I was wondering if any of you could help.

I also am using the Crucial m4 256gb SSD but it isnt my first try at SSD. I originally bought a ADATA Pro 256GB SSD but after installing in slot 0 and moving my stock ASUS drive to slot 1 the system BIOS wouldn't even detect the ADATA drive. I tried in other slot and by itself but no luck at all. The crazy thing is when i booted off my orginaly drive and the SSD was still in the system when windows loaded it detected the drive and i was able to format it and copy files to it. So i know the drive is working fine it is just the ASUS BIOS that is not detecting it. It even shows up when running the Windows 7 64bit install but windows gives you an error and will not let you install on the SSD drive.

So I got savy and took the Crucial m4 SSD drive out of my work laptop and cloned it to the ADATA, the ADATA works fine in my Dell work laptop. So i started testing my ASUS with the m4, as soon as i installed i was able to detect in the BIOS. I was so excited, even was able to install Windows with no problems. However, about 9 out of 10 times when i boot up I get a Hard drive read error, press Cntrl Alt Del. I just reboot and try a bunch of items and sooner or alter get lucky and windows loads up fine. It is super fast when it works but for some reason it is hit or miss.

Any advice or help would be greatly appreciated, i have spent the past two weeks calling ASUS tech support and have gotten nowhere. They tell me the drive is bad and i know that is not the case. I also am in AHCI mode and always have been. Also was looking into downgrading my BIOS from 209 which i have currently to an older version. I found one article where someone said this worked.

Thanks in advance!

02-16-2013, 11:28 AM
Contact @cl-Albert about it, and see what he can do for you. Considering that both SSDs are having problems, there could be an issue with your SATA controller.

02-17-2013, 01:56 AM
Thanks, just sent him a private message. Appreciate the help!

02-17-2013, 02:35 AM
Thanks, just sent him a private message. Appreciate the help!

No problem, let us know how it goes! :)