PDA

View Full Version : g75v display problem



jobwallis
02-13-2013, 11:13 AM
Hi
I'm having an intermittent screen flicker on/off issue. Had the machine around 6 months and performance is the best of any machine i have ever owned. BUT in the last week or two the screen has been turning off and on. This seems to be dependent upon the position of the machine ie placed upon a desk top it seems fine and will work fine all day though to much pressure on the keyboard or the casing around will cause a "display off". Placing on my lap is much more likely to result in the issue, so much so that sometimes display is totally non functional and I shut the lid and wait for a while . I should note that it is a display issue only and is not a system issue ie no crash or warning message.
So my assumption is that it is a video card or screen connection issue.
Questions
Anybody had similar issues?
Anybody had experience claiming warranty in Australia? This is my 3d graphics work machine and time is money.
Cheers

rewben
02-13-2013, 07:07 PM
it sounded like a connection issue. you can try to connect the laptop to an external computer monitor to rule out the gpu issue.

i'm not sure about warranty in Australia. perhaps you could get such information from your retailer.

Skull6
02-13-2013, 09:22 PM
Where's Nackers when we need him? He seems to be one of our subject matter experts on all things "down unda" around here... ;)

jobwallis
02-14-2013, 02:14 AM
good suggestion rewben.
Just spoke to service centre in Silverwater Sydney and they said 2-3 week turnaround time. Courier covered under 2 year warranty. machine is 6 months old. Reticent to send machine away for that long as i need it for work. Might have to pull out old HP Pavillion.

jobwallis
02-18-2013, 02:04 AM
can confirm its a screen issue - not GPU. I connected to alternative screen and replicated problem with only laptop screen showing display issue.

Pitcher@asus
02-18-2013, 03:30 AM
so is your laptop already send to asus service center now?

rewben
02-18-2013, 10:07 AM
@jobwallis, nice. i suggest you write down a note and leave it on the desktop of your laptop. if possible leave some pictures / videos there too so that the technician is aware of the problem (state that it's the problem of connection to the display panel) when you start the RMA.

jobwallis
02-19-2013, 01:56 AM
@Mike_Lu@ASUS , No have not. Can't let go of my professional work horse. Will grin and bear it for now I think. @rewben - will do if i go through with it. Good suggestion.

jobwallis
11-13-2014, 02:21 AM
update - it stopped doing shortly after my last post. never sent service centre.
no idea why it resolved itself.