PDA

View Full Version : G74SX - Satanic Trackpad



flclfool
02-19-2013, 08:22 PM
Hello, I'm aware this issue is kind of infamous with this model of notebook. I in the past had off and on issues with this computers trackpad, more recently though have updated to Windows 8, and for a time that had resolved those problems. Just today my pointer has starting twitching wildly like a squirrel on cocaine. My "Disable trackpad if usb mouse is connected" option has never worked for more than an hour.

At the moment my most pressing issue is to get this sucker disabled because I'm about to flip out. I've reviewed the drivers list several times and do not see any trackpad drivers... Since windows 8 update, the drivers that allowed some fn shortcut functionality have been unusable (but that didn't matter to me much). I have checked and fn + f9 does not disable the trackpad.

I have also tried downloading a Synaptics 16.3.9.0 (confirmed) from another site that a moderator on these forums linked; that just made it even more sensitive and crazy. I at least need this disabled so I can get some work down while maintaining my sanity. Ultimately I would hope there is some fix for this issue that way I can utilize the trackpad when a mouse is not available, as well as it's drivers features.

Anybody have some advice for me :( SOS

cl-Albert
02-19-2013, 10:08 PM
Welcome to the forums! Can you try to enter the bios through the 'F2' key and go to the 'Advanced' menu to disable the 'Internal Pointing Device'/Touchpad?
It might be a little tricky to get into the bios with Win8 installed, so try to hold the 'F2' key as soon as you power on, or try to get into it by holding 'F2' when you restart Win8 which can sometimes be a little easier.

Your G74Sx model will probably not have the option to enter the UEFI bios through the Win8 'Advanced Startup' options that the notebooks sold with Win8 will have, but you can still get into the bios using the methods above.

Myk SilentShadow
02-19-2013, 10:13 PM
Have you gotten the latest Win8 ATK Package? it's what you need to use Fn+F9 to disable the trackpad.

diamond
02-26-2013, 02:50 PM
Sometimes after a long period of leaving the trackpad disabled I got this 'satanic' effect when I turn it back on and my solution so far for this is to reboot the notebook... I know it is not the best solution but works for me and I'm curious to know what would solve the problem for good.

dstrakele
02-26-2013, 08:03 PM
Satan exerts his evil control over your touchpad through improper grounding (see http://rog.asus.com/forum/showthread.php?9639-G74SX-touchpad&). A metallic tape is used to ground the touchpad and due to poor manufacturing, was not properly applied to effectively ground the device.

@Brodyboy provided a good discussion on this issue in http://rog.asus.com/forum/showthread.php?883-Troubleshooting-ASUS-G73-Touchpad-Problems/page41. This problem was first encountered with G73 touchpads and has been mostly eradicated in the recent G75/G55/G46 series.

Note that the key players in the threads on this issue can no longer be contacted here. @Chastity, once known as the "ASUS erratic touchpad expert" hangs out at the Notebook Review Forum these days. @Brodyboy hasn't been seen on this forum since he fell into the abyss battling with the Balrog that Satan sent after him for exposing his demonic touchpad possessions.

flclfool
02-26-2013, 11:19 PM
Thanks for the replies everyone!
@Albert - Defninitely hoping I don't have to use that means but I will try it after the WIN8 ATK package magic, thank you for the idea :D
@Myk - This will def be my first attempt at a fix! Tyvm
@Diamond - Thing is I've never had it disabled, and restarts do not fix the issue :(
@dstrakele - This sounds very interesting :\ darn... I will try to fix the issue temporarily since I don't use the TP all the time (usually moused in). Thank you for the links!!