PDA

View Full Version : G75VX Synaptics Touchpad Buttons Stop Working At Random Times



wratharrow
02-20-2013, 08:42 AM
hi everyone.

i recently acquired a G75VX (because i couldnt get a G75VW anymore) and everything was working fine defaulted at windows 8, until 2 days ago, i started to have trouble getting the 2 physical buttons of the touchpad to work. the buttons would sometimes work, but most times just stop altogether. the touchpad itself is still functional - it's just the buttons that stop fucntioning. Some of the things I've already tried are: Reinstall the synaptics drivers, switching operating systems (used a linux live CD and windows 7 installation disc), upgrading the bios to 205. reinstalling the drivers didn't work, and the buttons didnt work either in the Live CD and Windows 7 Disc methods. the Bios upgrade didnt do much either. can anyone suggest what else i could try to fix this? the entire unit works fine with a mouse but sometimes i just want to reduce the clutter on my desk / lap so i just use the touchpad but i am not a big fan of tap-to-click so i need the help of the physical buttons.


thanks in advance.

cl-Albert
02-20-2013, 07:29 PM
Welcome to the forums! I haven't had a chance to try out the G75VX yet, but it sounds like a hardware issue with your unit although it can be less clear with new models.
Anyway, if you still have time to exchange/replace the unit with your store, you may want to keep an eye on this deadline and try this route.

Did you notice if it makes a difference where you press on the touchpad buttons and do both the left and right buttons have problems?
Anyway, it sounds like you have just about eliminated any software issues, so you may want to get your notebook checked or replaced.

wratharrow
02-21-2013, 03:18 AM
thanks for the reply. yeah it looks like i'll have to get it replaced. hopefully the replacement warranty is still good. (less than a month). yes, i can confirm that both buttons get disabled at the same time whenever this happens while leaving the touchpad functional. looks like it's a hardware problem. i hope the suppliers can get it replaced soon as i need this unit for work. :(

adrytowel
06-22-2013, 11:06 PM
I seem to be having a similar issue on my G75 vx. Every once in a while (seemingly at random) the left mouse button below my track pad stops functioning. Additionally, the track pad will stop registering taps. However, right clicking still works. Also, I can sucessfully left and right click if i plug in a USB mouse. Restarting generally solves the problem (sometimes requires multiple restarts).

This seems like a software issue. I am running the latest Synaptics driver.

Has anyone else had this issue, and/or solved it?

cl-Albert
06-25-2013, 07:27 PM
I'm actually a little worried about the hardware, but you might try some of the ideas below.

1. Check if the problem happens in Win8 Safe Mode which would likely indicate a hardware problem and let us know if you have any trouble getting there since 'F8' no longer works to do this.

2. For the left-mouse button issue try pressing in different areas like the left edge or right edge with different pressures to see if this makes any difference. Can't imagine what would stop the touchpad to stop registering taps though.

3. If you haven't been using it, stick to the G75VX touchpad driver on the ASUS download page (http://support.asus.com/Download.aspx?SLanguage=en&m=G75VX&p=3&s=388) to see if this makes any difference.

Hope this helps!