View Full Version : ASUS X75VD - Cant press two keys and mouse click

02-22-2013, 09:49 AM
Hi folks,

Hopefully you can help me with this. Its been bugging the heck out of me, and all my Google-Fu has lead to no results.

Picked up an X75VD (the little label in the corner lists it as a F75V, but the ASUS detector on the support site reports it as an X75VD) and I love the thing, but I'm having a problem while gaming. When playing both WoW and Minecraft, if I push two keys at once, (W and A for example to move diagonally) and then try to click my mouse, the mouse does not respond. Ive tried it with the touchpad built in AND an external USB mouse.... Also, Ive tried it outside of games and I get the same issue

Ive found a lot of reference to Palmcheck which supposedly disables the touchpad while you're typing, but all the directions to disable that won't work as I don't have the same options...

Any suggestions/tricks to get it to work?

Thanks for your time!

02-22-2013, 11:09 AM
Check the touchpad options in the control panel, and they will be under a tab marked something like "Synaptic". Those kinds of settings are in the driver for the touchpad, not in the Windows settings. Most of the touchpads I have seen are Synaptic-made, so the instructions are for their drivers.

Try pressing other keys and moving the mouse at the same time, and see what happens. If it is a particular set of keys, it can be due to the scan matrix of the keyboard. For instance, my G53SX cannot press the "V", "B", and "N" keys simultaneously.

02-24-2013, 02:22 AM
I can't find the Synaptic options - Here is what I have for Mouse options

Control Panel (http://meriwoker.dyndns.org/~crimson/Mouse/MouseOptions.jpg)
Elan SmartPad 1 (http://meriwoker.dyndns.org/~crimson/Mouse/MouseOptions2.jpg)
Elan SmartPad 2 (http://meriwoker.dyndns.org/~crimson/Mouse/MouseOptions3.jpg)
Elan SmartPad 3 (http://meriwoker.dyndns.org/~crimson/Mouse/MouseOptions4.jpg)

Also, I tried other combinations of keys, and I can replicate the error with any keys plus the external mouse AS WELL as the internal touchpad when the mouse is not connected

03-01-2013, 06:58 AM
Nothing? :\

03-01-2013, 11:22 AM
Sorry for not getting back to you earlier - been busy and forgot about this thread. The Elan settings are fine. Try reinstalling the ATK package (keyboard driver) and Elan (touchpad) drivers and see if that helps.

03-06-2013, 10:45 AM
Its ok, things get busy ;)

I have tried reinstalling the touchpad and the keyboard drivers. Still getting the same error, both with the touchpad and an external mouse - however I did notice something weird. Its only happening with LEFT clicks. Right clicks work fine