PDA

View Full Version : G53SX Solid State Drive (SSD) Issues



jmacre
03-01-2013, 04:41 PM
All,

I wanted to summarize the issues i have been experiencing with my G53SX when trying to upgrade to a SSD drive.

I am now using a Crucial m4 256gb SSD but it isn't my first try at SSD. I originally bought a ADATA Pro 256GB SSD but after installing in slot 0 and moving my stock ASUS drive to slot 1 the system BIOS wouldn't even detect the ADATA drive. I tried in other slot and by itself but no luck at all. The crazy thing is when i booted off my original drive and the SSD was still in the system when windows loaded it detected the drive and i was able to format it and copy files to it. So i know the drive is working fine it is just the ASUS BIOS that is not detecting it. It even shows up when running the Windows 7 64bit install but windows gives you an error and will not let you install on the SSD drive.

So I got savvy and took the Crucial m4 SSD drive out of my work laptop and cloned it to the ADATA, the ADATA works fine in my Dell work laptop. So i started testing my ASUS with the m4, as soon as i installed i was able to detect in the BIOS. I was so excited, even was able to install Windows with no problems. However, about 9 out of 10 times when i boot up I get a Hard drive read error, press Cntrl Alt Del. I just reboot and try a bunch of items and sooner or later get lucky and windows loads up fine. It is super fast when it works but for some reason it is hit or miss.

Any advice or help would be greatly appreciated, i have been working with Albert at ASUS and have tried a few different things but still no luck. I also am in AHCI mode and always have been also turned on the ASUS boot logo and sounds to help slow down the boot process and help the drive be detected.

So can anyone tell me what drives they are using if they have upgraded to SSD? Also where you able to have an SSD and another drive connected at the same time? What Bios version are you running? (I am on 209)

Appreciate the help and advice.


Jeff

pablitopm
03-01-2013, 08:05 PM
Hello jef, im an owner of g53sw, and i have 2 drives, one ssd and the other one that came with the notebook, i have to reinstall windows in my ssd drive because i mess it up when i wanted to copy the disk that came with my pc to the ssd.. i did a fresh re install and everything works wonderfull. i've purchased a samsung ssd of 128gb i dont exactly know the model of the ssd but it was the best i could find!

edit: i have bios 203

Zygomorphic
03-02-2013, 01:19 AM
I am running BIOS 209 on mine, and it works perfectly with my OEM (Hitachi 640GB) drive and my user-added Seagate Momentus XT (500 GB Hybrid). I do not have an SSD, so I can't help you there, but my G53SX detected the Seagate in slot 1 perfectly on the first try. The drives you bought should work, considering that they are quality drives. What other BIOS settings do you have enabled?

jmacre
03-05-2013, 08:25 PM
Bios settings are:
Always been in AHCI mode since day one.
Played with the UEFI boot but have had is disabled for some time now. No difference either way.
Have the SSD to boot 2nd and CD to boot first. Have tried to install other drives and always have issue booting so i have been using with only the M4 Crucial drive.

Zygomorphic, You mention your "user added" that Seagate Momentus drive was the drive i got stock with my system.

Any other help would be greatly appreciated! About ready to sell this laptop and go buy a different brand. So disappointed my ASUS laptop doesn't work with SSD. So crazy, that's like my Honda CD player in my car not playing CD's.


Thanks

Zygomorphic
03-05-2013, 08:44 PM
The drive that comes stock with your computer varies with the particular model line (mine was cheap, you got a higher-end model of the same system).