View Full Version : G75VX Wireless Problem

03-04-2013, 03:52 AM
Hi guys,

I don't know yet if this is a hardware problem with the laptop or a problem with the router as it only happens with my ASUS laptop. When I try to play games my game will randomly spike (loose packets) Sometimes even dropping connection from the server. It happens at complete random. If I am in a Skype call it will also randomly drop out at any moment. If I choose a wireless bandwidth automatically it tends to make the internet more stable for a period of time but after the connection starts to drop out again. I tried updating the drivers to the latest on the Asus website but that did not seem to help the situation.

any suggestions or ideas would be greatly appreciated,


03-04-2013, 05:22 AM
Check to see if there is any firmware or software updates available for you wireless router. Also if you have cable or satellite internet check the same for the equipment. You might just have a conflict or a compatibility problem.

Just a suggestion. Good Luck

03-04-2013, 06:05 AM
I can't update the firmware on the router as Bell updates it automatically, I have not had these problems on any of my other wireless computers in the house. The connection seems to get more stable when I set it to channel 5 but eventually it cuts out again (after 15 minutes) and does not stop after that.

03-04-2013, 07:45 AM
make sample environment to test or change other rute to test, if you do all sw or trubleshoot, please send back to asus service center to check.

04-24-2013, 08:15 PM
I am getting the exact same problem here. Is it possible to have an official answer / solution from the Asus support team ?

There is nothing to do with router or modem but only with the wireless card. I tried different router and 4 different laptop and the ROG G75VX is the only one having issues. Very fustrating when connection drops in a middle of a fight when I am gaming.

Sending back the unit is probably not the right solution. If we are many with this issues, that mean it's not a isolate problem and can probably only be resolve with a driver update or a new wireless card ( different model )

Matrix Leader
04-24-2013, 09:32 PM
Make sure you have latest updated WiFi driver.

For me updating the Atheros WLAN driver to v10.0.0.225 fixed the problem

I don't know which wireless adapter your laptop has. let me know and I can help you get an updated driver

04-25-2013, 09:09 AM
Don't use the wireless but ONLY the cable.

Then go to the battery menu down on the right and put it high performance ( Gear4performance) I think.

04-25-2013, 09:25 AM
I had the same problem with my wireless router and I do have cable connected to the wireless router, and no connection attached to the G75VX laptop the W8 has a software that allow me to connect and to communicate with my wireless router I had to update the Atheros WLAN driver to v10.0.0.225 fixed the problem also make sure you're firewall is set correctly.

04-27-2013, 09:11 AM

just make sure your drivers are up to date and double check your wireless adapter under device manager and go to power management tab and make sure that the first option is unchecked. this might be the cause of your issue.

04-27-2013, 04:37 PM

i keep getting random "!" sign when I'm playing. is it something to do with the fact that the G75's network is a 802.11b and that wireless connections run with a 802.11n? i can't find any drivers cause mine is a windows 7 (and no i dont plan on upgrading to 8). Any suggestions?

05-06-2013, 03:18 AM
Hey guys, where did you find the Atheros WLAN driver v10.0.0.225 ? I didn't see it on the G75VX download page.


05-09-2013, 05:45 PM
Hey guys, I have the same problem with my new G75vx. I dont have the Atheros WLAN, instead, i got the Broadcom 802.11ac Wi FI adapter. I tryed everything that is written on the asus help guide for WIFI, Nothing worked. Im hoping to get some help here first before sending it back ... The notebook was opened yesterday ......

Also Im on a bell router too, but i currently have a g71gx and i never had any problem with the wi fi before......

07-04-2013, 04:50 AM
Try this link.

07-04-2013, 04:53 AM
Any1 here uses Asus RT-N66U?
I cannot detect 5G on my ROG lappy but my other older laptop can discover.
Using driver Atheros v10.0.0.205 (Win8 Drivers) but I am running Win7.

07-04-2013, 05:19 AM
Opps, tot ROG series should be a high end machine yet the Wlan does not support 5G, seems like a normal laptop Wlan works better, disappointing.

The highly-integrated AR9485 targets the value computing market. The AR9485 provides a complete WLAN solution–media access controller (MAC), baseband, and a high–performance 2.4 GHz radio in a low–cost digital CMOS design.

07-04-2013, 06:34 AM
somebody posted link for dell driver (M14xR2_Network_Driver_8XV7H_WN_6.30.95.26_A00) I found it works the best, asus 66 desktop driver in win 7 may fry card cause of power settings.

Dell drivers, you frigggnnn suck. If I wanted to use DELL drivers Jonny I woulda bought a DELL!!!!

I had a decent chance of getting escalations to work on getting us a working win 7 driver, but I'm sure mr Marketing killed any chance of that!
Thank you Mr Marketing Marshall@Asus. Send all complaints to him/her until their system overheats and splatters cryo all over them. Helium Cooled Joke. lol
No not really.

07-04-2013, 06:40 AM
I'm considering getting a MAO tattoo, if it means he/she get's an especially uncomfortable LOGAI Cell. LOL

Yes, WE PAY NO SAY...it is still true...and yes you SUCK!!!

07-07-2013, 07:37 PM
I had some issues with my WiFi to I just used Driver Genius updated my driver end everything worked without problems. This was on win 8 though. You could try to find drivers with some software similar to Driver genius, there are free ones on the net. Maybe this will help with win 7.

And please guys be respectful to each other, if you don't like this forum don't be a part of it, and you have to understand that some people around here are just doing their jobs.