PDA

View Full Version : Clean Windows 7 on Asus G75VX (Win8 pre-installed)



bjurn
03-04-2013, 10:40 AM
Hello!

I had been lurking around here trying to figure out either a good way to move my Windows 8 (core-oem) installation to my new SSD or install Windows 7. No post that i found had an easy route to follow so i thought i write down a quick "guide".

Backstory: I was originally trying to re-install my Windows 8 to the new ssd.. Did not work, even Asus support said the Windows 8 "embedded" into the bios could not recognize the SSD as a suitable drive since it only worked on original hardware. I then asked, what if the harddrive went haywire and did not work anymore ?
They told me to get support from Microsoft as they could not do anything about this matter.

So back to scrapping Windows 8 and doing a fresh-o-so-clean Windows 7 installation on the SSD.
Before you start throwing rocks at me about drivers and such, i got everything to work. Even WIFI (thanks to *will edit for link*).

Nearly every driver on the support disc can be installed on Windows 7, expect for chipset and Wifi (chipset i got off newest G75VM Windows 7 driver download page).

Use an external drive, flash drive or just dvds to transfer every picture, game file or whatevz. to.

Installation (http://www.youtube.com/watch?v=rMlsfk10PUA).

Enter bios, rapidly spam your F2 key when the computer turns on.

- Switch to "Boot" and set “Launch CSM” to Enabled.
- Switch to "Security" and set "Secure Boot Control" to Disabled.
- Press F10 to save and exit.

(quoted Rewben)

Now, only have the SSD harddrive inside the computer where the HDD was before.
Put everything back together.
Load the dvd drive with a "legally" owned copy of Windows7 Ultimate.

And install.

Now, after this is done. Windows 7 will not find any drivers. So pop in your Asus support dvd.
Install the ethernet card.

If you dont have a ethernet option, figure something out.

Launch Windows Update, and update everything!

Now the system will find all the hardware.

Install all the drivers.

Chipset, audio blablabla.

And finally wifi drivers HERE (http://www.asus.com/Networking/PCEAC66/#support_Download_29_DRPCEAC666309526Win7)
Thanks @rledge21 for providing wifi driver.

Over and out.

rewben
03-04-2013, 12:20 PM
sweet! thanks a lot for your help, @bjurn :)

finally someone with the right model wrote the right guide for others!

mcvc69
03-10-2013, 02:35 AM
Cheers for the great info, i have g75vx with win8 in it, want to go for win7 and manually install all the drivers , are there any websites of each of every single drivers/bloat wares / junk apps that i do not need to install ?

bjurn
03-10-2013, 04:03 PM
I just installed everything i could off the support cd/ or checked for newer drivers off the vx support page.
Apart from all the trial crap and such that is also on the cd.
Still working great after a couple of weeks, nothing i miss from Win8.

mcvc69
03-11-2013, 04:32 AM
Thanks Bjurn, just a quick question, do you find the sound quality of G75VX bad ? I've compared G73's sound quality with G75VX, G75VX's sound quality blows, it sounds so off, while G73 is so much better and acceptable, I dont know if its driver's problem or bad quality of speakers/sub woofer ...... I am on latest driver from Asus official website already, any suggestions or any ways to fix it ? or would the sound quality be better on windows 7 ? I am right now on windows 8, hate the OS so much, gotta get a time to downgrade to win7

g75user
03-11-2013, 11:54 AM
Hey guys, is there something wrong with windows 8?

rewben
03-12-2013, 01:12 AM
@g75user, some users switch the OS due to their preferences; although some claimed there are compatibility issues with games (most probably old games)

mcvc69
03-13-2013, 02:13 PM
Hi Bjurn, I just did what you said, done installing windows 7, but the Asus Driver CD i have from this laptop is only support for windows 8 64bit only, I tried to put into my dvd rom and says this disc supports windows 8 only, what can I do to get all the drivers for windows 7 ?

rledge21
03-13-2013, 05:02 PM
Hey guys, is there something wrong with windows 8?

I booted into windows 8 for the first time. installed chrome. rebooted like 20 minutes later - and it was broken. wouldn't boot, repair, safe made, restore. tried to fix for 2 hours before I formatted & installed linux/win7 dual boot w/ no uefi

rledge21
03-13-2013, 05:05 PM
Hi Bjurn, I just did what you said, done installing windows 7, but the Asus Driver CD i have from this laptop is only support for windows 8 64bit only, I tried to put into my dvd rom and says this disc supports windows 8 only, what can I do to get all the drivers for windows 7 ?

here you go: http://rog.asus.com/notebook/17-inch/g75vx/

how come you guys all got driver CDs? I got nothing :(

glad my tip about the Win7 wifi drivers made it onto here, I couldn't post on the forums when I discovered it.

mcvc69
03-14-2013, 02:52 AM
here you go: http://rog.asus.com/notebook/17-inch/g75vx/

how come you guys all got driver CDs? I got nothing :(

glad my tip about the Win7 wifi drivers made it onto here, I couldn't post on the forums when I discovered it.

Thanks rledge21, shall I just install the wifi driver that people post on this forum ( http://www.asus.com/Networking/PCEAC66/#support_Download_29_DRPCEAC666309526Win7 ) and not touch those wireless drivers on the page you just linked ? or shall I install all of them ?

mcvc69
03-14-2013, 06:16 AM
G75VX here, tried the driver rledge found, doesnt work for me, the driver doesnt have setup.exe files after extract, tried to load the folder manually from device manager, sofar there are 3 devices with question marks on the icon, 1. Network Controller 2. PCI Simple Communication Controller 3. Universal Serial BUS(USB) Controller, tried right click and update the driver and locate the extracted folder, windows 7 says cant find driver software for your device. anyone help ?

bjurn
03-14-2013, 07:22 PM
Thanks Bjurn, just a quick question, do you find the sound quality of G75VX bad ? I've compared G73's sound quality with G75VX, G75VX's sound quality blows, it sounds so off, while G73 is so much better and acceptable, I dont know if its driver's problem or bad quality of speakers/sub woofer ...... I am on latest driver from Asus official website already, any suggestions or any ways to fix it ? or would the sound quality be better on windows 7 ? I am right now on windows 8, hate the OS so much, gotta get a time to downgrade to win7

I always use headphones, but ive noticed the crappy speakers. Sounds like every sound is beeing pumped through the sub or something ?

Had another Asus non-gamer laptop before this one, had loads better speaker quality then this one. But doesnt bother me that bad, have a good soundsystem for music.

bjurn
03-14-2013, 07:23 PM
Hello mcvc69, i browsed the cd and went into each and every folder to the installer and installed that way since i got the same message from trying to open the setup.

bjurn
03-14-2013, 07:25 PM
G75VX here, tried the driver rledge found, doesnt work for me, the driver doesnt have setup.exe files after extract, tried to load the folder manually from device manager, sofar there are 3 devices with question marks on the icon, 1. Network Controller 2. PCI Simple Communication Controller 3. Universal Serial BUS(USB) Controller, tried right click and update the driver and locate the extracted folder, windows 7 says cant find driver software for your device. anyone help ?

Also yes there is not setup for the drivers, you go to the hardware thingy select the "?" on the network card and browse to the files (drivers) and select them. Shouldv added this into the guide! sorry.

mcvc69
03-15-2013, 03:07 PM
yea thats what I did but win7 still says cant find driver software for your device

bjurn
03-15-2013, 04:45 PM
yea thats what I did but win7 still says cant find driver software for your device

Have you updated everything with Windows Update ? (if not legal version, dont install the k******* update (search for it online)).
If it still doesnt find the hardware dunno whats wrong :<

mcvc69
03-15-2013, 08:47 PM
solved now for the wifi driver for G75VX, downloaded from Asus G75VX support page, the older Atheros Wireless Lan Driver and Application Version V10.0.0.205 down at the bottom in the Wireless section. from http://www.asus.com/Notebooks_Ultrabooks/G75VX/#support_Download_36 and install it, worked fine now. thanks ~

rledge21
03-18-2013, 09:39 PM
You should definitely try the drivers from the asus website first. If none of the wireless ones work for you, its likely you have the same chipset I do. In this case you will want to try the drivers at the link in the bottom of the OP.

The hardware id of my chipset is 14e4:43b1. I'm not sure how to list the hardware id in windows, but you can use 'lspci' command in linux to see it. Also, I bought the model Best Buy sells.

nova6
03-30-2013, 01:50 PM
I am in the middle of downloading all drivers, windows updates now. The problem I am having is when I go to reboot, I get the blue screen. Any thoughts??

slaughter71
04-02-2013, 03:57 AM
Hi Bjurn, I just did what you said, done installing windows 7, but the Asus Driver CD i have from this laptop is only support for windows 8 64bit only, I tried to put into my dvd rom and says this disc supports windows 8 only, what can I do to get all the drivers for windows 7 ?

ya you need to use the windows 8 disk.. BUT use teh new nvidia gpu drivers just released..
also if you want blue tooth you need to manually force it through the device manager.
when prompt search for windows 8 disk,, goto the software/bluetooth folder and click next,,it should find it from there..

cl-Albert
04-02-2013, 10:29 PM
how come you guys all got driver CDs? I got nothing :(


For those that haven't wiped out their original ASUS Win8 image yet, check under the C: drive for the 'eSupport'/'eDriver' folder which will have a copy of the driver disk that you can burn to DVD, or just copy to a USB stick.
Run the AsInsWiz, InstAll, or something similiar in the root folder to 'autorun' the disk and see the installation menu.
The Filelist.txt file lists the driver versions, but check the ASUS download site for the latest approved drivers if necessary.

khai7
04-03-2013, 04:51 AM
Hello MR Bjurn, before i began to post i would say sorry if i offended you, i am using G75vx i purchase it in Malaysia(SEA) (purchase date 23 March 2013) and like you i try to upgrade my HDD(1TB form factory) to SSD(now using SanDisk 128GB Ultra 7mm) so i try install my self by clone software but fail( successful in term clone but some security lock in bios setting) so i went to Asus Service Centre( LOW yak Plaza Kuala lumpur) i ask them is possible for me to install SSD they told me there 2 bios lock built into bios then after unlock you may clone OS (my G75 come win 8) and i ask next question Can Asus service centre install for me? Asus service centre say "YES - 2 working days" i agree and hand it over 2 days i got back with SSD install and big fat smile on my fat face :))

"well moral of the story just bring it to Asus Service Centre" :)

khai7
04-03-2013, 04:54 AM
Asus did not charge me lol i offer to pay them they say u just purchase it and still under warranty :) (but i did buy service men counter and tech Starbuck latte :)

cl-Albert
04-03-2013, 09:47 PM
Hi khai7,
That's great! I expect the service center installed Win8 on your G75Vx instead of Win7 though, so for the G75Vx customers that want to install Win7, they want to follow bjurn's suggestions in this thread since ASUS doesn't currently provide support for Win7 on the G75Vx.

johnnydwicked
04-06-2013, 12:34 PM
Can anoyone tell me how to fix the wifi issue? My wifi is always on! I went to the Asus site and download the G75vx wireless radio control which enable or disable airplane mode which is the on and off switch for my wifi. But the drivers doesn't come with setup.exe installation or instructions on how to install it. Please help!

khai7
04-07-2013, 07:15 PM
Can anoyone tell me how to fix the wifi issue? My wifi is always on! I went to the Asus site and download the G75vx wireless radio control which enable or disable airplane mode which is the on and off switch for my wifi. But the drivers doesn't come with setup.exe installation or instructions on how to install it. Please help!

hello, you want it g75vx to start with wifi off you mean? or how to off wifi? i just fn+f2... airplane mode.. on/off

khai7
04-07-2013, 07:24 PM
Hi khai7,
That's great! I expect the service center installed Win8 on your G75Vx instead of Win7 though, so for the G75Vx customers that want to install Win7, they want to follow bjurn's suggestions in this thread since ASUS doesn't currently provide support for Win7 on the G75Vx.

hello, yes they install my ori win8, or clone it... but i still miss win 7 lol but win 8 problem is no start button but i fix it with classic shell win start button and disable metro...

cl-Albert
04-10-2013, 11:38 PM
Can anoyone tell me how to fix the wifi issue? My wifi is always on! I went to the Asus site and download the G75vx wireless radio control which enable or disable airplane mode which is the on and off switch for my wifi. But the drivers doesn't come with setup.exe installation or instructions on how to install it. Please help!

Unfortunately, I haven't tried this yet, but if you are running Win7 on your G75Vx, does Fn+F2 do anything for the wireless, or do Fn+F5 and Fn+F6 dim and brighten your display while showing your brightness levels on the screen when you change them (if not, we may need to check if you installed the ATK driver)?
The G75Vx Win8 wireless radio control utility might not help for Win7, but there should be a PNPINST64.exe file included in the files that will install it for you.
Anyway, hopefully others can help you solve it if there are still problems.

mynewrog
04-18-2013, 01:16 PM
My plan was exactly the same as the OP's: Buy an SSD and move Windows 8 there while use the 1TB SATA for storage purposes. I can confirm I got the same response from various ASUS support sessions and I was also redirected to Microsoft Support believing it would not be possible to do this until I figured a work-around. A few words of caution:

1) The method provided by ASUS support using a recoveyr drive doesn't work. By using a 16gb flash drive the system is always "Unable to reset your pc" as "A recovery partition is missing" even though you have included it when doing the recovery creation. They will think you've created the flash badly and tell you to re-create it but it is not the case. It's all down to Windows not being able to recover if the flash drive used is of a smaller size than the hard disk containing the recovery partition (it's the case 99.9% of the time unless you use a flash of 1TB size!)

2) Do NOT ever ever ever follow the advice about contacting MS support. I did and all the guy was able to tell me was that my Windows had been "locked" because I tried to install them on another drive and make me worry for nothing. Totally useless step.

3) What I did and actually worked fine was this: Leave Windows 8 installed and get Acronis True Image (or other similar software). Install the SSD and swap the 2 drives (put the SSD on the hdd bay where the SATA is, and move the SATA to the left bay). Windows 8 will still boot with no problem. Once the SSD is in, go to Acronis and choose Clone Disk. Let it clone your SATA to your SSD (it will automatically copy all the original partitions proportionally). Then remove the SATA and see your system booting fine from the SSD. Your SSD will then be able to recover windows and reset your pc at any time since it will have the recovery partition copied to it.

After that I connected my SATA to another computer just to safely delete all partitions without any confilicts but maybe you can do this in your G75 as well, haven't tried that. And finally I re-installed my empty SATA to my G75, formated, job done and Windows 8 are now fully transferred to the SSD.

PS. Although Windows 8 will make you lose way more time and annoy you in the most simple everyday things you use to do but it's more like a matter of being able to use them on your SSD because you have every right to. Cheers.

Mcblazer0
04-23-2013, 02:38 AM
I've got a G75VX-RH71-CA laptop that came with G75VW Win8 and Win7 support discs and neither one is accepted on my laptop. They won't run. I have got Win7 Pro installed on my Samsung 840 Pro 128GB SSD but that was as far as I could go with no drivers. Do you have the Win7 support disc for a G75VX? Could I somehow get a copy?

Sesimie
04-23-2013, 01:48 PM
Ok lurked around and finally had to post.

I have a G75vx-TS72 and i reformatted my boot drive. (crucial M4 SSD made to boot using macrium reflect)

Unfortunately i installed a windows 7 ROG theme and i was no longer able to see my taskbar or desktop (yup i used classic shell for the win7 start button)

I decided that i'd play with win8 but i'm a windows7 ultimate fan for a long time. Sadly i reformatted my SSD to have my Clean install of Win7 ulti 64-bit....after install i reach desktop for the first time sequence....then the laptop restarts...and a blue-screen appears with what looks like memory addresses.

I've been able to do memory diagnostics....and also load drivers off of my Asus Driver and utility disk. But windows7 wont start in safe mode or normally. always the blue-screen. After i attempt to fix with startup repair.....i get Bad Driver and Status offline errors.


currently looking for a Windows 7 ultimate sp2 install (not probable) with hopefully the correct drivers...

Any advice / help would be appreciated.

Sesimie
04-25-2013, 12:25 AM
Ok i got my windows 7 ultimate sorted.....had to go through all wifi drivers i could find from asus...:cool:

rewben
04-25-2013, 06:50 AM
just curious, what's your wifi adapter?

Mcblazer0
04-27-2013, 02:29 AM
I have finally got Win 7 Pro on my G75VX- RH71-ca complimented with a new speedy Samsung 840 Pro SSD; all the hardware working; thanks to your help bjurn, rledge21 and the rest of you.... Anyone interested in a copy of the drivers maybe we could figure a way of getting them to you... Most came from the software discs that came with my laptop. I got 2; a G75VX and a G75VW disc. A lot of the ones on the Win 8 G75VX disc were also compatible with Win 7 but the Win 7 G75VW disc was an asset as well. The only one driver that I couldn't find was the wireless adapter but rledge21 saved the day... love my ROG laptop but couldn't handle Win 8... maybe later when I don't have a choice...

Sesimie
05-01-2013, 06:18 PM
just curious, what's your wifi adapter?


i downloaded all drivers from asus support site...but finally in my Device Manager

Asus 802.11ac Network adapter

The older asus driver i used were extracted to this folder name...win7-10.0.0.221-whql

Sesimie
05-01-2013, 07:06 PM
Question....where do i get working thunderbolt drivers? (not pressing as i don't use TB for now)

Fatrick
05-02-2013, 08:35 PM
I've updated to Windows 7, and all the drivers are installed properly and working fine, but the function keys are not working except for the brightness controls. (ie keyboard light, trackpad toggle, sound, etc. are not functioning)

Is there another driver that controls these, or a piece of software that needs to be configured?

Anixter
05-05-2013, 07:23 PM
Anyone with a G75VW can give me the partition layout in it order
trying to get mine fixed to restore again
thanks

mynewrog
05-11-2013, 04:15 PM
I've updated to Windows 7, and all the drivers are installed properly and working fine, but the function keys are not working except for the brightness controls. (ie keyboard light, trackpad toggle, sound, etc. are not functioning)

Is there another driver that controls these, or a piece of software that needs to be configured?

+1

Same problem here? Do we know what we need to install as practically disables keyboard backlight completely and Audio can't be controlled with FN keys (quite useful).

PS. Problem Solved: Just go to the G75VW support page (link below) > select Windows 7x64 > Utilities > ATKACPI driver and hotkey-related utilities Version V1.0.0026 (Global). It will install and work like a charm! Now my happiness with Windows 7 is complete... :o

http://support.asus.com/download.aspx?SLanguage=en&p=3&m=G75VW

pka4916
05-24-2013, 12:59 AM
What are these options?

Switch to "Boot" and set “Launch CSM” to Enabled.
Switch to "Security" and set "Secure Boot Control" to Disabled.

Will this disable UEFI ?

pka4916
06-03-2013, 12:07 AM
I changed the setting but cannot get it installed. I wiped out the partitions but its stuck at a gpt partition and cannot make it to a mbr partition
Now what?

Disabled Secure boot
Reboot
Enabled CMS (can't enable that without reboot)
Boot with a boot disk.
tried diskmode (or whatever the name was)
to do a clear disk 0 etc
or convert from GPT to MBR

I can't do any of them...
What are you suppose to do???

pka4916
06-03-2013, 10:54 PM
nobody has an suggestion or tell me that it's not possible anymore ?

rewben
06-04-2013, 02:59 AM
nobody has an suggestion or tell me that it's not possible anymore ?

can you please tell me what you wanna achieve?
1. doing clean install with UEFI boot; or
2. doing clean install with BIOS boot?

it's not impossible; but if you do it wrong it will become impossible.

pka4916
06-04-2013, 05:55 AM
All I want is get rid of windows 8, and install Window 7.
I followed the steps, about Enable CMS and Disable secure boot.
but it won't let me install it.. I cannot make a partition. due to it's GPT.
so I guess it's without UEFI(?)

rewben
06-04-2013, 12:47 PM
All I want is get rid of windows 8, and install Window 7.
I followed the steps, about Enable CMS and Disable secure boot.
but it won't let me install it.. I cannot make a partition. due to it's GPT.
so I guess it's without UEFI(?)

it seemed you could boot and you're in the installation screen. now try this:

1. after you are in the installation screen, press shift+f10 to get the command prompt. type diskpart.
diskpart> list disk
diskpart> select disk num (replace num with the right disk number, e.g. 0)
diskpart> clean
diskpart> convert mbr
diskpart> exit

2. exit the command prompt and proceed the installation.

pka4916
06-04-2013, 01:43 PM
Hi,

diskpart> list disk
diskpart> select disk num (replace num with the right disk number, e.g. 0)
diskpart> clean
diskpart> convert mbr
diskpart> exit


I had tried this already, but it was telling me that it wasn't allowed.
Clean did wipe everything out. bit the Convert mbr wouldn't let me do it.

rewben
06-04-2013, 02:59 PM
uh? if you booted from the boot disk, you still have that message?! that's weird.

what if you do this?
diskpart> list disk
diskpart> select disk num (replace num with the right disk number, e.g. 0)
diskpart> clean all
diskpart> convert mbr
diskpart> exit

pka4916
06-04-2013, 03:59 PM
Yes, I booted from my USB Windows 7 stick. (same as the disc)
Did delete all partitions,
tried to make new ones, was getting an error..
So I went into the repair option, so I could go to the command prompt. and followed the diskpart items. and same problem,

rewben
06-04-2013, 04:53 PM
now what if you do this?

diskpart> list disk
diskpart> select disk num (replace num with the right disk number, e.g. 0)
diskpart> attributes disk clear readonly
diskpart> clean all
diskpart> convert mbr
diskpart> exit

can that command in red be executed?

by the way, can you please put here the exact error message? i'm sorry but this is the first time i encounter such a weird case.

pka4916
06-04-2013, 11:34 PM
ok, I will try that..
btw.
what's the difference between
1. doing clean install with UEFI boot; or
2. doing clean install with BIOS boot?
?

rewben
06-05-2013, 01:03 AM
the differences are:
UEFI mode
1. your target hard disk/ssd must be GPT;
2. your installation media must be able to install OS in UEFI mode

BIOS/legacy mode
1. your target hard disk/ssd must be MBR;
2. your installation media must be able to install OS in BIOS mode

i have written some notes on how you create the usb boot media for each mode here (http://rog.asus.com/forum/showthread.php?28758-GUIDE-G55-G75-Upgrade-Notes&p=224827&viewfull=1#post224827).

since you have problem converting the drive, and it remained as GPT disk, you can try convert your usb media to support UEFI instead (well, unless you wanna use the convenience of BIOS/legacy mode for things like linux installation)

pka4916
06-05-2013, 01:20 AM
What would be preferred for Windows 7 ?
UEFI or MBR ?

iS uefi making your windows 8 boot up faster... so it will be in windows 7 as well..
or is that just a Windows 8 feature

rewben
06-05-2013, 02:13 AM
What would be preferred for Windows 7 ?
UEFI or MBR ?

iS uefi making your windows 8 boot up faster... so it will be in windows 7 as well..
or is that just a Windows 8 feature

imo it depends on what you wanna do. by default i would suggest uefi because the bios should be optimized for this mode, with w8. however, if you really need to have legacy options, by all means.

w8 is 'faster' on boot (if you enabled its fast boot feature); the rest is almost the same.

pka4916
06-05-2013, 03:00 AM
ok, then I'll use the UEFI mode..
I've read your other post about booting with that..
with UEFI, stays the HD in GPT mode then? or do I still need to MBR, since I couldn't install it the first time

rewben
06-05-2013, 04:10 AM
now you have a gpt disk, you just need to create the usb stick that can be used to install w7 in UEFI mode. follow the steps i have highlighted in the notes. then boot with it (select uefi:<usb.stick> to proceed)

pka4916
06-05-2013, 11:56 AM
ok, taking my laptop to work, so I can make a new backup and try this again.

- Switch to "Boot" and set “Launch CSM” to Enabled.
- Switch to "Security" and set "Secure Boot Control" to Disabled.
- modified USB stick with \efi\boot\ and the loader efi file

Ready to roll again..

pka4916
06-05-2013, 03:35 PM
This is so weird.
Doing the same thing... and now it's installing..
without using the diskpart procedures
I was able to delete all the partitions now in my windows setup.. (which before it was hidden)
Could it be that I added that EFI file in the Boot folder ???

pka4916
06-05-2013, 05:30 PM
OK..
Got almost everything to work.
The only item that I don't have drivers for is the USB controller ?
It's not in the edriver folder.
Where can I get those?

and the button next to the power... how can I get that one to work again?
I'm thinking that's the Gear something... program.. but couldn't install that one. since it's win 8 only.

rewben
06-06-2013, 12:45 AM
This is so weird.
Doing the same thing... and now it's installing..
without using the diskpart procedures
I was able to delete all the partitions now in my windows setup.. (which before it was hidden)
Could it be that I added that EFI file in the Boot folder ???


OK..
Got almost everything to work.
The only item that I don't have drivers for is the USB controller ?
It's not in the edriver folder.
Where can I get those?

and the button next to the power... how can I get that one to work again?
I'm thinking that's the Gear something... program.. but couldn't install that one. since it's win 8 only.

ah.. that's why it would not work in the first place! for the conversion to work the target disk must be blank.

i thought 'clean' in diskpart will clear all partitions and volumes but apparently it did not do that!

yes, it worked because those are the setup to install w7 in efi mode.

for the usb driver, you can use the one from g75vw or g46vw (which ever is newer). for the rog button to work you need atk package, and power4gear. they're all at asus support page (http://www.asus.com/Notebooks_Ultrabooks/G75VX/) (goto support link then download link to get to all latest drivers), or here (http://rog.asus.com/notebook/) (choose your model from the list of the laptops below).

pka4916
06-06-2013, 01:43 AM
ok... got everything installed now..

Still have 1 open driver

Universal Serial Bus (USB) Controller
PCI bus 0, device 20, function 0


But no clue what belongs to it..
it's none of the edrivers... so it might be a setup file I guess... but don't know which one.


1 thing I noticed with Windows 7 now, is that it seems that the internet is much slower.
and some other things in general are slower..

Edit: internet is slow :(
1 laptop with Win 8 = 40Mb
1 laptop with Win 7 = 380 Kb
Both running on Wireless Network.
wth happened... is that the wireless driver?

rewben
06-06-2013, 02:38 AM
great :)

from your description for that unknown usb device, you have to install usb 3.0 driver. can you please share the hardware id to confirm? (you can find that out from device manager > the unknown component > properties > details, select hardware ids from the property list.

for the slow wifi, make sure the power plan is set to high performance; then uncheck the "allow computer to turn off device" in the power management tab of that device in device manager.

pka4916
06-06-2013, 02:44 AM
I wil check that..

btw.. I see why everything is so slow.... 4 of the 8 processors are in Park mode... so they are not used.
changing the powerplan, doesn't make any difference..


edit

the ID's are

PCI\VEN_8086&DEV_1E31&SUBSYS_201F1043&REV_04
PCI\VEN_8086&DEV_1E31&SUBSYS_201F1043
PCI\VEN_8086&DEV_1E31&CC_0C0330
PCI\VEN_8086&DEV_1E31&CC_0C03

rewben
06-06-2013, 02:54 AM
yeah confirmed you need the usb 3.0 host controller driver (Intel USB3.0 Driver). get that from the download page of g75vw.

pka4916
06-06-2013, 02:58 AM
Thanks.
Any idea how to solve the slow speed and slow wireless speed ?

rewben
06-06-2013, 03:05 AM
yay.. good to know everything is fine for you now :) well, *almost*

er.. i am not so sure about this sorry. i had a different atheros wifi previously and now i am using intel 6235. it's better you consult others who have the same card. good luck!

pka4916
06-06-2013, 03:09 AM
Thank you for all your help, to get Win 7 sorted out.
Going to make an image, so I can go back and forth...
Download from 10 sec to 2 hrs.. is way too much

rewben
06-06-2013, 03:26 AM
Thank you for all your help, to get Win 7 sorted out.
Going to make an image, so I can go back and forth...
Download from 10 sec to 2 hrs.. is way too much

hey no problem.

i haven't read anything about the wifi not working afaik. i think you can get more useful helps from the owners of g75vx which have converted to w7.

pka4916
06-06-2013, 04:45 AM
MAde a Win 7 image, and put Win 8 image back, and I am blasting on full speed.

btw. I still have "Secure Boot" disabled.. and win 8 runs fine...
What is the purpose of that "Secure Boot" ?

rewben
06-06-2013, 10:36 AM
secureboot is supposed to be a 'security' feature that rely on uefi (read here (http://www.webopedia.com/TERM/M/microsoft_secure_boot.html) or here (http://en.wikipedia.org/wiki/Unified_Extensible_Firmware_Interface)).

for the default OS (in your case, w8) it will play nicely. for other OS's it's useless. apparently it is abused and exploited in the name of security, as a means to prevent OS's other than the stock OS from installing into the machine (it also prevents live media, such as liveUSB from booting).

Haze69
06-27-2013, 10:09 PM
Is it possible to install Windows 7 with UEFI and Secure boot? It felt like windows 7 loaded much slower

rewben
06-28-2013, 12:43 AM
@Haze69, no. unfortunately it is not possible.

on the other hand, w7 and w8 are different especially in the boot process. w8 has the fast startup / hybrid boot so it sure boots much faster.

mrinds
06-28-2013, 04:21 PM
I too was able to get a clean install of windows 7, but the 64bit ver. of home premium. But I think the way I did it was backasswards. I ended up deleting all windows 8 partitions. I think it is the worst installation since Vista. Then I just popped in the win7 installation disk and installed. No problemo. Still, I wouldn't recommend that procedure for everyone who owns the g75vw. Only those who really hate wins8.

tW0st3p
08-11-2013, 03:21 AM
I used this guide to install windows 7 on my g75vx, bought two new SSD's and use one for gaming and the other for OS. But the problem I have is that my keyboard jumps back and forth. "fn" button and specials doesnt work completley. I can type and all of a sudden i jumpes 3 sentances back and Im typing in the middle of another sentance. Very annoying

atra.stella
08-25-2013, 06:32 PM
i want to downgrade to win7x64, is it advisable to downgrade? i use my machine for gaming. does this method work 100%?

Pitcher
09-27-2013, 09:43 PM
I used this guide to install windows 7 on my g75vx, bought two new SSD's and use one for gaming and the other for OS. But the problem I have is that my keyboard jumps back and forth. "fn" button and specials doesnt work completley. I can type and all of a sudden i jumpes 3 sentances back and Im typing in the middle of another sentance. Very annoying

Install the Keyboard Device Filter then reboot, your problem will be solved:

Keyboard Device Filter Utility 1.0.0.5 (http://dlcdnet.asus.com/pub/ASUS/nb/DriversForWin8/KBFilter/KBFilter_Win7_64_VER1005.zip)

riboild
10-08-2013, 12:50 AM
I have successfully installed windows 7 64bit but unfortunately I am having a problem with laptop freezing up after approximately half an hour. I have checked on essentially all the drivers and updated them all but it almost seems like the ssd I installed, a crucial m4 128ssd, is causing trouble... i did a health checker on the ssd but it shows 98 percent health. anybody got some recipes for success here??? I am wondering why it freezes, any advice is greatly appreciated!!!

riboild
10-08-2013, 12:51 AM
I am running a g75vx with an ssd 128 m4 and a 750gb wd black hard drive btw

Baern
10-23-2013, 12:56 AM
Hey guys, i just bought a g75-vx, pretty much tried everything. This thing wont boot from DVD and just freezes during the logo load. The USB doesnt work AT ALL. I installed a win 8 version EASY. But even when i try to go through the OS to install, it gives me an error that i should retry the installation. i have a deep hatred for windows 8 and it feels like using vista, i need to get this laptop to be NOT windows 8 lol. Thanks, i will keep chugging along. Thanks :)

bjurn
11-20-2013, 07:55 PM
I have successfully installed windows 7 64bit but unfortunately I am having a problem with laptop freezing up after approximately half an hour. I have checked on essentially all the drivers and updated them all but it almost seems like the ssd I installed, a crucial m4 128ssd, is causing trouble... i did a health checker on the ssd but it shows 98 percent health. anybody got some recipes for success here??? I am wondering why it freezes, any advice is greatly appreciated!!!

I would go to power options, and check off "turn off after **", that will stop the freezing, or atleast did for me!

veneyeth
01-12-2014, 03:44 AM
I got everything working except for what seems like the Bluetooth in device manager... any thoughts.


BCM20702A0
USB\VID_13D3&PID_3404&REV_0112
USB\VID_13D3&PID_3404

wow days and now I feel like a dumbass..............
As im writing this I found a solution
pop the utility disk in and update the driver
point windows to the utility disk and kabooom!
there ya go.

Asus_G72GX
05-09-2014, 03:14 AM
Enter bios, rapidly spam your F2 key when the computer turns on.

- Switch to "Boot" and set “Launch CSM” to Enabled.
- Switch to "Security" and set "Secure Boot Control" to Disabled.
- Press F10 to save and exit.

(quoted Rewben)

These options are not exist in Asus G75VW with BIOS 223, only Launch PXE OpRom available in boot tab. Also there is no any switch to disable UEFI boot. Is it possible to install Windows 7(MBR only) on BIOS version 223?
And how is it possible to set BIOS to Legacy mode as currently I have only HDD's?

BANDAID
07-19-2014, 02:55 PM
Hi bjurn ive joined the forum just to say thanks for this post....i was getting totally stressed with the wifi driver search.....BRILLIANT JOB !!!

GrasslandShield
08-08-2014, 07:52 PM
Hey guys, is there something wrong with windows 8?

There is plenty wrong with Windows 8, my friend.

Hey guys, if I may,

I'm installing Windows 7 on my G46, and it's been a long trip but I've got it allllmost done. Right now, I'm trying to find my wifi drivers. When I go to the Asus website for the drivers and download them, it's like they're all for Windows 8, they don't work at all.

I need to find drivers I can use for Windows 7 on my G46. Can anyone give me a hand?

Honestly, it looks like I'm probably missing a lot more than the wifi drivers. Is there somewhere I can find drivers that are compatible with my machine?