PDA

View Full Version : G46VW and Razer Naga



versions
03-07-2013, 02:50 PM
Hello everyone. I made a thread here a while back and recieved my G46VW yesterday. Very happy with it so far.

Anyway, I've run into one issue. I use my Naga (on num key mode) for a bunch of binds in WoW and when num lock is disabled on the laptop, buttons 1 to 9 use a shift modifier (num 2 becomes down etc) and the last 3 are fine. If I enable num lock, the buttons all work like they're supposed to but half the keyboard is now a numpad. I'd like to use my Naga but use the keyboard like I usually do.

Sorry if it's not a very good explanation, bit hard to explain, I suppose.

Thanks in advance.

gypsymoth
03-07-2013, 07:11 PM
I'm not at home now, so I can't look at the bottom of my Razer Naga. I remember there is a switch down there. I can't remember what exactly does the switch do. My memory tell me it switch between straight number mode vs. number pad mode. I think you'll want it in straight number mode.

Pitcher@asus
03-08-2013, 02:09 AM
alos check manual to setting or search from google.

cheek
03-08-2013, 02:40 AM
i hv g75 and the naga... didnt rreally understand the problem...
win 7 or win 8?
did u installed the synapse 2.0?
http://www.razerzone.com/software-support
if u did install it...perhaps not letting it run at start up will help. and even perhaps the settings are in synapse 2.0 and will solve the problem?
and i assume when u switch to the '123' key mode at the bottom of the mouse it didnt solve your problem right?

bignazpwns
03-08-2013, 04:48 AM
Its the craptastic razer software. I use a Naga epic some times and what makes it crap is the software. i only use the drivers i dont use the wow software and i bind with the built in settings for wow.


Also go ahead and pm me your system specs i wanna get some number from you with how the G46 handles wow and raids with ultra and 8x MSAA

versions
03-08-2013, 11:56 PM
When it first happened I didn't have any Razer software or drivers on the computer. I have Windows 8.

The issue is it essentially uses the keyboard buttons, so if num lock is enabled, it works fine, but with it off, it instead uses arrow keys, page up & down, etc. I e-mailed Razer support and they told me to download Synapse, and firmware. I just did it, didn't help. I'll e-mail them back and post any solution I find in this thread. If anyone knows how to fix it, that'd be greatly appreciated.

And bignazpwns, I'm afraid I don't raid at all. I'm flying in the Vale of Eternal Blossoms right now, and I have it completely maxed with 8x AA. I also use a lot of addons. I'm sitting at 30-35 FPS here. In Orgrimmar, instances etc I hover around 50-80. At most, I get like 150. I have the i7 3630QM, 8GB RAM and a 7200RPM HDD.

EDIT: I can't use the number mode because I use those keys for other binds, I have a lot and need a lot of buttons. I'm not sure as to what the cause is, I'll plug in a keyboard and see if it happens, because it doesn't on my rig.

EDIT 2: Nope, didn't help. Starting to lean towards a Windows 8 or laptop issue, since it works fine on my proper computer. I'll try it on my netbook.

EDIT 3: Odd, same issue. It runs Windows 7 so it pretty much has to be the Naga.

bignazpwns
03-09-2013, 12:54 AM
Ok here is a guide to fix that problem.

1- Turn your mouse over
2-Turn the switch from NUM to 123
3-Enjoy.

123 is the number keys on the kb. NUM is your num pad.

versions
03-09-2013, 01:25 AM
I use the num keys on my Naga for binds and I use 1-7 number keys for other binds, I need it on num mode.

bignazpwns
03-09-2013, 01:30 AM
Then you need to set this up in wow. The naga has one of two settings. Num pad and numbers thats it. Anything more you need to set up with macros and shift modifiers or another software.

gypsymoth
03-09-2013, 01:31 AM
Try plugging a full size keyboard into your G46VW and try playing with the full size keyboard and the Razar Naga. I'm not saying that's a solution, even though it can well be. But I suspect the full-size keyboard will work just like your other setup, which gives you further insight into the real cause of the problem.

versions
03-09-2013, 02:18 AM
Try plugging a full size keyboard into your G46VW and try playing with the full size keyboard and the Razar Naga. I'm not saying that's a solution, even though it can well be. But I suspect the full-size keyboard will work just like your other setup, which gives you further insight into the real cause of the problem.
I did just that earlier in the thread and yes, the error persisted. I've tried it on 3 machines, 1 of which is a desktop and the other 2 are laptops with no numpad.

gypsymoth
03-09-2013, 03:20 AM
Then I think it's time to get down to the details. Tell us about this "perfect" machine where the Naga and the keyboard just works on WOW. Separate details for the machines that work and machines that don't work. Even reading your latest two sentences (3 machine) confuses me on what works on what. We need details like the following:

Desktop machine
104 Key USB keyboard
Naga mouse (bottom switch set to ...)
This machine works.

Laptop machine (model?)
built-in keyboard with separate number pad.
Naga mouse (bottom switch set to ...)
This machine doesn't work.

Laptop
internal keyboard without separate number pad.
But using 101 Key PS/2 Keyboard
Naga mouse (bottom switch set to ...)
This machine works.

You catch my drift?