PDA

View Full Version : G75VX / Win7 HP: Fn key functions & headphone plug not working



verkkopeli
03-10-2013, 01:07 AM
Hello,

This is my first post here, so hi everyone! I'm an old WinXP/AmigaOS/C64 user (read: gamer/demoscene follower) who took a step to the dark side and decided for once to "save time and let others do the preparations". The consequences follow Murphy's Law...

I bought a G75VX and wanted to keep away from the horrors of Win8. So, I asked whether the reseller could do a clean install of Win7 for me, removing the factory-installed Win8 in the process. They agreed to do that, and to install all the necessary drivers and updates as well.

I received the machine yesterday, and nothing seemed to be out of order at first. However, I soon discovered that connecting the machine to my external speakers or headphones achieves nothing - sound comes through the internal speakers only. On top of that, the Fn key (ie holding it and pressing any key) does nothing, and even more strangely the 'mute' button under the HDA Speaker icon (the one next to the desktop clock & date on a default desktop) does not respond to clicking on it even though the volume slider works fine.

I'm aware the correct first solution to my problem (I hope) is "contact the reseller ASAP", which I already have done. Since they failed to notice the problems (and won't be there to answer me until next week) and seeing that this site enjoys the presence of some truly well-informed people, I would like to ask whether anybody here knows what might be the cause behind the machine's odd behaviour (aside my own combined laziness and stupidity of course).

Windows update claims everything is up to date, and the update history shows that the people at the reseller seem to have installed just about all the necessary drivers. Still, to me the symptoms appear to point towards some missing or incompatible drivers, but which ones should I be looking for? Sorry for my ignorance, it's my first baby steps with both the mighty G75VX and WIn7.

Here are the basic specs:

Model G75VX-T4016H
17.3" FHD (1920x1080) Non-glare
Intel Core i7-3630QM (max. 3.40GHz)
NVIDIA GeForce GTX 670MX
8GB (2 x 4GB) DDR3 1600MHz + an extra 2 x 4GB of the same type installed at purchase
750GB 7200rpm SATA
DVD SM DL
WIndows 7 Home Premium (Windows 8 64-bit originally)

verkkopeli
03-10-2013, 01:49 AM
Oh well. It appears I've been had by the reseller. Installing the latest RealTek and ATKPackages fixed most of the problems - and I suppose the buggers haven't installed much of anything else aside the NVIDIA video drivers despite charging me for doing it. Time to send a constructive email to their superior.

One problem persists still, Fn + F9 does not disable / enable the touchpad. I'll get me another missing driver now...

By the way, the machine feels incredibly cool (literally too). Upgrading from a 2006 Celeron 1,6 GHz / one GB RAM to this monster is surreal :)

rewben
03-10-2013, 02:15 AM
my best guess is missing drivers:

1. for fn keys: install atk package;
2. for sound: this might be due to audio driver also. install the latest one from asus should resolve the problem.

edit: oh you got that :) sweet! get the touchpad driver for fn+f9 to work.

verkkopeli
03-10-2013, 01:38 PM
Yep, the touchpad driver was missing also. I installed it yesterday and now everything is working flawlessly. Thanks for the quick reply!