View Full Version : G46VW touchpad [solved]

03-11-2013, 07:23 PM

I just got a G46VW, got everything installed but can't seem to get the touchpad working properly. By that I mean the basic stuff of scrolling using a swipe. By researching this issue on the internet I also read that it supports multi-touch gestures? I didn't even know that when I bought it :)

I installed the ATK package and Elan driver from the support website, it shows up in Device Manager as ELAN PS/2 Port Smart-Pad but can't do anything except moving the cursor around. Fn+F9 to disable/enable it doesn't work either.

I'm using Windows 8. Any help is appreciated.

03-11-2013, 09:49 PM

Below is a screenshot from my G46VW Win8 test unit.
Check the taskbar in desktop mode for the touchpad icon and double-left click to open the ASUS Smart Gesture settings for the touchpad.
Use the menu at the top for other settings and there is short video for each setting that shows you what it does and how to use it.

My Elantech touchpad driver version is which is the only version posted on the ASUS download site for the G46VW, but you may want to double-check your driver version.
Confirm other Fn keys are working like Fn+F11 and Fn+F12 for audio volume (you should also see the onscreen display for the volume appear while you are changing it by holding the 'Fn' key and pressing 'F11' or 'F12' repeatedly), but I didn't see any problems toggling the touchpad on and off through Fn+F9.
A tiny red circle with a slash appears on the touchpad taskbar icon when it has been disabled using Fn+F9 as in the screenshot below and the touchpad has temporarily stopped working.

Hope this helps!


03-12-2013, 08:11 AM

Thanks for the quick reply.

My driver version is also, but I don't have the touchpad icon in the tray nor do I have an Asus Smart Gesture software installed. Is this a separate download (because I didn't find it) or was it supposed to be bundled with the touchpad driver?

Also, all other Fn combos work (except the touchpad one).

03-12-2013, 09:24 AM
Nevermind, seems to be one of those weird-twilight-zone-situation. I installed some other driver which replaced the elan one, nothing happened, I then reinstalled Elan over it and now it shows up in the tray and the gestures work :)

Thanks for the help.

03-12-2013, 11:12 PM
Glad to hear you could get it working, and thanks for the feedback.
This is more for others that are interested, but the Smart Gesture software is part of the Elantech touchpad driver and not a separate download.

Yeah, I'm not sure if this happened in your case, but I remember hearing before customers installing other software for their external mouse that would 'kick out' the touchpad software from the Vista or Win7 mouse properties, so customers could only use one or the other, but not both at the same time.

06-17-2013, 02:01 PM
thank you SO MUCH for mentioning fn+F7 - mine has not been working for ages, but this has fixed it!! brilliant cheers, i am shocked it was something as simple as that!!! Was ready to chuck the whole thing through the wall!!

06-17-2013, 05:36 PM
Welcome to the forums! You mean your touchpad has not been working and you were able to use Fn+F9 to get it working?
Glad to hear you could get it working and thanks for the feedback! Hopefully it can help others in the same situation.