PDA

View Full Version : Charger making weird sound



skyrider
03-12-2013, 09:43 PM
I noticed this only recently but whenever the charger is plugged at both ends (into the laptop + into external power socket)

it makes a subtle but constant buzzing noise, as if a tiny little fan is spinning inside making slight screeching noise.

whenever i pull the plug at either end the buzzing stops immediately, only to resume when plugged in again.

I am not sure if the noise started only recently or if it has been there all along (i got this laptop 8 months ago), the noise

itself is really hard to hear unless the charger is close to me.

Has anyone experienced similar issues? Should I get a new charger? I have a G55VW by the way.

Dreamonic
03-12-2013, 10:01 PM
This is completely normal for our switching PSU. It's sounds more like a high pitched whine than buzzing.

The noise will go away when it's being loaded more (games, programs, charging.. etc) or when unplugged.

If your power adapter was faulty, you would be experiencing power related symptoms (turning on, staying on, system instability, extremely hot to the touch .. etc.)

Zygomorphic
03-12-2013, 11:16 PM
No worries about the charger. The transformers inside make a faint noise at times. It depends on how good your hearing is (mine is terrible for being <20 years old - and it is not due to listening to loud music FYI). If it is faint, then there is nothing to worry about.

UnAimed
03-12-2013, 11:32 PM
What your describing is called Coil whining or Coil noise. Rest assured, this does not damage or interfere with the operation of the charger, in other words it's quite normal.

See here for a explanation:

http://en.wikipedia.org/wiki/Coil_noise

There might be some ways to reduce it or have it disappear completely. Try plugging it into a power extender equipped with Ground.

skyrider
03-13-2013, 01:22 AM
phew, thanks for the quick response guys! Guess I was worried for nothing :p

heyyieyimen
03-03-2019, 07:21 AM
I am currently having this issue right now. is this normal for newer models? I am currently using an ROG GL553VD