PDA

View Full Version : G75VX Gaming Performance Issue(Stuttering) :



mcvc69
03-15-2013, 09:24 AM
Hi there, having some gaming performance issue on G75VX here, running Diablo 3 on highest setting except shadow at medium, resolution 1920x1080HD. The game stutters when theres alot of things going on for example in D3, when fighting with elite packs with lots of affixs like frozen, arcane enchanted, with weather snowing(Stonefort map), fps will drop to 30 from 60 and the game stutters, it first I thought its Diablo 3 itself, then I tried another game Dota 2, same thing happens as well, when fighting at opponents base where there are alot of buildings and Heros on the screen, it will stutter too.

Laptop Bios Version : 204
Graphics Card : GTX 670MX. tried 3 different nvidia drivers : 1.Asus's latests one (Version V9.18.13.1100.02) 2. Asus's older one(Version V9.18.13.0707 ) 3. Nvidia's official latest beta driver 314.14. all with same result.
OS: Windows 7 64bit
HD : Plextor M5 Pro 256gb SSD with latest firmware 1.03, tried 1.02 as well.. same.
CPU : i7 3630qm
RAM : 16GB
The Windows 7 is fresh installed with no bloatwares/junkwares.
Always on High Performance Mode.
Windows 7 Experience Index from top to bottom : 7.6 7.8 7.4 7.4 7.9

Before I bought this laptop I did alot of reviews and most of the feedback says this laptop can run most of games perfectly on max setting. It is unacceptable for such expensive laptop to have such performance for just Diablo 3 and Dota2 , these two games ain't even require that high spec of computer to run perfectly....

Could anyone please give me any suggestion on where it can be tweaked/fixed?
if this is how 670MX performs then I will probably sell this laptop away and get something else with better graphics card like GTX680M :(

DirtyCodingHabitz
03-15-2013, 10:23 AM
I play Dota 2 every day and it runs 100% smooth on my G75VX. Have you updated to the latest beta nvidia driver? HERE (http://us.download.nvidia.com/Windows/314.14/314.14-notebook-win8-win7-64bit-international-beta.exe) custom install it and do a clean install.

Also try Adaptive Sync and see if that fixes it. Go to Nvidia control panel - Manage 3D settings - Global Settings, and choose "Adaptive" in Vertical sync.

ZeroBarrier
03-15-2013, 10:27 AM
Are you running the games unplugged? :confused:

mcvc69
03-15-2013, 10:37 AM
DirtyCodingHabitz: Tried the 314.14 beta driver, latest yes , as I wrote on original post :) and yes its always custom installed and clean install, still the same result, gonna try the thing you mentioned in Global Settings, do you run on windows 8 ? i am thinking is it because VX comes with windows 8 only would that possibily means its designed for windows 8 and if we run this laptop on windows 7, the performance wont be as good ? whats your OS like? and other specs on laptop ? did you o/c or add more ram etc?

ZeroBarrier : of course not, plugged full time, it is pretty much common sense that running unplugged decreases performance since it will try to save battery :P

DirtyCodingHabitz
03-15-2013, 12:41 PM
Here are the specs of mine MLN (http://www.mln.com.au/product/?itemID=4277#specs). I'm running Windows 8 and got all the latest drivers.

Try disabling your anti-virus or firewalls that you installed, or close them just in case they aren't still running in the background.

mcvc69
03-15-2013, 01:34 PM
Dont have firewall and anti-virus, I guess the difference between yours and my G75 is the OS and RAM then, you are on win8 and I am win7 , you have 32G Ram I have 16G.

I've tried the Vertical Sync - Adaptive, I think its much better now , FPS does drop to 50 from 60 instead of 30 from 60, I am not sure, will test somemore again. thanks :)

Anything else I can tweak from Nvidia control panel ?
Did you tweak the Nvidia control panel or it came adaptive on default? mine was "use the 3D application settings" by default...

DirtyCodingHabitz
03-15-2013, 03:58 PM
Nothing else was tweaked. All my games run smooth. Maybe you should install Win8 and see if this still happens.

Kawazu
03-15-2013, 05:15 PM
I have the same problem with Diablo 3 but i have not tried Dota 2.
Dont think there is anything wrong with your system, i have msi afterburner running all the time so i can see the GPU load and during those effects i go from a 50-60% gpu load to 99% so the fps drop explains itself.

Some ppl might say that they dont see any fps drop or notice anything but "most" ppl cant even see tearing from v-sync being off so i do no longer trust in opinions from people on forums any more unless they have some sort of picture to prove that the fps is 100% stabel at the same spots that have a problem with

mcvc69
03-16-2013, 10:42 AM
Anybody installed Intel Rapid Storage Technology on G75? Do you think it would make difference on performance ? and whats the best driver version for it? I didnt want to try because I read it somewhere once you installed theres no way to uninstall it since it wont show up in control panel > uninstall programs

httuner
03-16-2013, 01:03 PM
Turn your shadow effects to low or off, shadow effects can take a huge hit in performance even with high end video cards. It takes a lot to create shadows, I know my GTX580 would struggle if I set my shadow settings to high and thats on a desktop video card. Try it first and check back with results.

mcvc69
03-16-2013, 04:52 PM
Turning V-Sync off runs much better on FPS and no stuttering but I see screen tearings..... :mad:

Httuner : tried turning off shadows, still stutters with v-sync on. and v-sync off runs good but screen tearing happens

DirtyCodingHabitz
03-17-2013, 12:55 AM
Turning V-Sync off runs much better on FPS and no stuttering but I see screen tearings..... :mad:

Use Adaptive Sync to run games smoothly and to get rid of the tearing.

mcvc69
03-20-2013, 07:28 AM
theres still screen tearing with Adaptive Sync :(