PDA

View Full Version : G51Jx - Weird Ethernet Problem



TiaNadiezja
03-16-2013, 09:43 AM
Hello!

I'm having one other issue with my laptop - it won't recognize that there's an Ethernet cable plugged in if it wasn't plugged in when the computer booted up. If I need to power cycle my router, or the cable comes unplugged, I have to reboot the computer to get it to recognize the fact that the cable's plugged in.

Any possible explanations?

dstrakele
03-16-2013, 11:52 AM
It could be an Ethernet driver issue with Windows 8. Does a Log Out/Login allow recognition of the connection?

You may have to wait for either a Windows 8 update or an Ethernet driver update to resolve the problem. I'm assuming you've already installed the latest driver from your Ethernet card manufacturer's website.

TiaNadiezja
03-16-2013, 11:54 AM
Do we know which Ethernet card the G51Jx has?

dstrakele
03-16-2013, 12:02 PM
You might - if you look in Device Manager. Me? I haven't a clue...

EDIT: I did some checking on the ASUS website and found out the G51JX ships with an Atheros Ethernet card. You should be able to obtain the latest driver for Windows 7 64-bit at http://www.atheros.cz/atheros-network-drivers.php.

Unfortunately, it doesn't appear a Windows 8 driver is available. Still, I recommend determining your model# from Device Manager and installing the latest Windows 7 version. There is a chance it may resolve your issue.

TiaNadiezja
03-16-2013, 10:43 PM
This works! The problem is completely resolved.